Hello,

working on an Opencart website using Wamp and Windows7.
Having trouble with Php settings _please view screenshot_
[IMG]http://img408.imageshack.us/img408/1097/phph.png[/IMG]

I've seen going through several sites with no solution so far; any help you could provide would be greatly appreciated.

regards,
C.

Member Avatar
diafol

Open php.ini file and remove the semicolon in front of the line:

;extension=php_curl.dll

restart apache / server


if this is on your remote server, perhaps the host has disabled it - if so - you'll have to talk to them.

Open php.ini file and remove the semicolon in front of the line:

;extension=php_curl.dll

restart apache / server


if this is on your remote server, perhaps the host has disabled it - if so - you'll have to talk to them.

Very much appreciated, thank you Ardav.

regards,
C.

Open php.ini file and remove the semicolon in front of the line:

;extension=php_curl.dll

restart apache / server


if this is on your remote server, perhaps the host has disabled it - if so - you'll have to talk to them.

I'm afraid the php.ini file hosted in my remote server doesn't contain the info you are referring to. Here's its content:

magic_quotes_gpc = Off;
register_globals = Off;
default_charset = UTF-8;
memory_limit = 64M;
max_execution_time = 18000;
upload_max_filesize = 999M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.use_cookies = On;
session.use_trans_sid = Off;
session.gc_maxlifetime = 12000000;
allow_url_fopen = on;

this is the only php.ini I can find. Could you kindly advise?

regards,
C.

I'm afraid the php.ini file hosted in my remote server doesn't contain the info you are referring to. Here's its content:

magic_quotes_gpc = Off;
register_globals = Off;
default_charset = UTF-8;
memory_limit = 64M;
max_execution_time = 18000;
upload_max_filesize = 999M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.use_cookies = On;
session.use_trans_sid = Off;
session.gc_maxlifetime = 12000000;
allow_url_fopen = on; this is the only php.ini I can find. Could you kindly advise?

regards,
C.

Member Avatar
diafol

Do you have full control of the php.ini file? You usually won't be allowed to mess with it directly in shared hosting. You may have a cut-down version in your account which allows you a modicum of control just over your stuff. I'm surprised that you don't have curl if they allow allow_url_fopen.
Anyway, you'll probably need to talk to your host - see if they have anything on their FAQ section or help forum before you post a help ticket.

You've done a phpinfo(); right? Just to see what's available to you.

Do you have full control of the php.ini file? You usually won't be allowed to mess with it directly in shared hosting. You may have a cut-down version in your account which allows you a modicum of control just over your stuff. I'm surprised that you don't have curl if they allow allow_url_fopen.
Anyway, you'll probably need to talk to your host - see if they have anything on their FAQ section or help forum before you post a help ticket.

You've done a phpinfo(); right? Just to see what's available to you.

I'll surely check with host; in the meanwhile I thought I owed you an answer to thank you for the support you've given:
after running phpinfo():

cURL support: enabled
cURL Information: libcurl/7.15.5 OpenSSL/0.9.8b zlib/1.2.3 libidn/0.6.5

regards,
C.