1

Hi all

Is anyone here familiar with coding in WolfCMS?

I have been asked to add a form page to an existing website based on WolfCMS, but have little experience on the platform. For some reason my form doesn't seem to be receiving the POST data, or executing the processing properly. Any guidance as to the requirements or configuration for the cms would be appreciated.

cheers
/H

3
Contributors
3
Replies
4
Views
5 Years
Discussion Span
Last Post by diafol
0

I am not familiar with that system, but some of us might be. Try posting the piece of code that is problematic and what error you get when it is run .

cheers

1

Apologies for the delay, was off last week for the holidays.

The page code looks like this

corp-info/order-form

<?php include './public/forms/order.php'; ?>
forms/order.php

<?php if ($_SERVER['REQUEST_METHOD'] == 'POST') {
// check the POST data
//   do some stuff with the database
}
...
<form action="<?php echo URL_PUBLIC; ?>corp-info/order-form.html" method="post" enctype="multipart/form-data" name="order">
...

For some reason it seems like the POST data is coming back to the page empty. If I do a print_r($_POST); at the top, I just get an empty Array() printed to the page.

Edited by |-|x: I'm stupid...

0

Show the form in its entirety. Do you get the error on page load AND after form sent?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.