Is anyone on here using FCKeditor filemanager? I know its quite old now, but it came with a CMS. I have been trying to upload some large zip files using the filemanager, but it just says unvalid file. When I've had a look round on the net, I found a suggesstion to add a htaccess file which specifies the max fileszie to overide the .ini file. When I've tried this though, I just get the "invalid XML response" error. Anyone managed to fix this?

Recommended Answers

All 3 Replies

copy, paste to notepad, save as anyNameYouWant.php, upload to your server, and then direct you browser to it.

  <?php phpinfo(); ?>

Look for the server API value and the loaded configuration file value..

  1. If Server API says anything about apache, then you can use the .htaccesss trick.

  2. If Server API says anything about CGI, fast CGI.. then you can add a new php.ini file in the root directory of your script. copy and save as php.ini and then upload to your server . Change 100M to your desired maximum upload file size. DO NOT use MB... this is very tempting in the minds of other to type MB.

        upload_max_filesize = 100M
        post_max_size = 100M
  3. Although not really necessary, except when you will be installing ffmpeg, mencoder on your server, then loaded configuration file value matters a lot. This is the php.ini file using by your server. This can be edited by way of SSH client like the PUTTY.

In most cases, people only need either 1 or 2 above.., but never both.

Thanks veedeoo - although I have the ability to use htaccess, it appears to be tripping some kind of bug in FCKeditor. However, the .ini approach - which I hadn't heard of before, worked fine!

Hmm.... Just tried this on another server and neither method seems to work, possibly .ini has been disabled by the shared hosting. MAybe its easier to get them to use FTP?

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, learning, and sharing knowledge.