0

My PHP page displays correctly on my localhost but after pushing it online it does not display; nothing shows even
when I inspect the source code. Any help?

3
Contributors
6
Replies
7
Views
5 Years
Discussion Span
Last Post by Biiim
0

Could be one of a million things. Likely suspects:
Is your remote site php-enabled?
Have you copied your files to the correct directory?
Has your domain been activated properly?
Does all the output in the page depend on php - e.g. include files or is there any vanilla HTML on it? Have you tried just uploading plain html in your php page to see if it displays?

Edited by diafol

0

All other files work except this particular one; it's the landing page right after login

0

It's probably a path thing. Any chance you can show the code and any error messages? Otherwise we'll just be guessing. My decrepit crystal ball is getting cloudy :(

0

Thanks Diafol; I also thought my path was faulty but my browser's address bar clearly states my path is correct :(

0

OK, have you got anything else to give us? Name of file? Problem URL? List of files in public root (just the relevant ones)? Do you have htaccess file and if so what's in it?

0

Can you view a plain text or html page on the hosting?

if so

Can you view a simple page with just echo "hi"; in it?

if so

turn on error_reporting(E_ALL); at the top of your script

Should narrow down the error a lot

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.