0

FOR FOLLOWING CODE
<%@language=VBScript%>
<%Option Explicit%>
<html>
<body bgcolor="aqua">
<%
Dim myConn
Set myConn = Server.CreateObject("ADODB.Connection")
myConn.Open = ("DRIVER={Microsoft Access"&" Driver (*.mdb)};DBQ="&"C:\Inetpub\wwwroot\tizagASP\razor.mdb;")
myConn.Close()
Set myConn = nothing
%>
</body>
</html>

I GOT FOLLOWING ERROR

The page cannot be displayed

There is a problem with the page you are trying to reach and it cannot be displayed.
Please try the following:

Click the Refresh button, or try again later.
Open the localhost home page, and then look for links to the information you want.
HTTP 500.100 - Internal Server Error - ASP error
Internet Information Services

Technical Information (for support personnel)

Error Type:
Provider (0x80004005)
Unspecified error
/tizagASP/tizagADO.asp, line 8
Browser Type:
Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.95 Safari/537.11
Page:
GET /tizagASP/tizagADO.asp
Time:
3 декабря 2012 г., 22:17:00
More information:
Microsoft Support

PLSSSSSSSSSSSSSSS HELP

4
Contributors
3
Replies
6
Views
4 Years
Discussion Span
Last Post by ptduran
1

you may want to try a new driver.

The problem you are having is most likely with your myConn.Open property. You need to use the correct drive for your pariticular scenario. If you are connecting to Access, you may want to try a newer driver especially if you have Office 2007+ installed.

Provider=Microsoft.ACE.OLEDB.12.0;Data Source=C:\database\Access2007file.accdb;
Persist Security Info=False;

some additional resources to help you...

ASP Database Access Using ADO

ADO Tutorials

0

If you are working with IIS on a 64-bit Windows, then you need to enable 32-bit applications in your IIS. To do so, start IIS, click Application Pools, select the appropriate Application Pool (Default Application Pool for all websites residing in wwwroot), select Advanced Settings from the right pane, set Activate 32-Bit-Applications to True. Then your connection should work.

0

Open IIS >> >> localstrat.asp >> properties >> from the security tab, click to clear the Anonymous Access check box, and then click OK. Think this should work

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.