Hi All,

Well once again I go round and round with IIS. I have got it to run with a little tweaking with ASP 1.1v but I can't get it to run with ASP 2.0.

Here are the variables:
Server
Hosted on IIS 6.0
Running Windows 2k3 Server
Not a DC
Fully Patched


Devolpment Machine:
Windows XP
VS.Net 2005 Pro
Localhost ASP runs beautifully


My Problem
Well I can create a ASP project on my XP IIS (5.1 I think) and it runs fine and debugs like normal. Well I tried creating it on the server. I first has the "Can't start debugging. Logon failure: Unkown username or password". Okay I thought I will just double check to make sure my Anonymous access is checked. Why yes it is. So I made sure Integrated Windows Authenticaion is checked, yes it is. I tried bunches of other stuff and still no where.
Here is what I have done:
Anonymous & Integrated Windows Auth is checked
Keep HTTP Alive is checked
Execute permissins is set to "Scripts only"
I do have VS debug installed on the server
Also did the aspnet_regiis.exe -i

I don't know what else to do. When I create a project in the server IIS it asks for a username and password. It will only take the administrator username and password. Then I try to debug it and no luck. If I do a start without debugging the website then prompts me with a username and password box to view the page.
We are running on a domain if that helps. Also it seems that it is passing the windows auth but isn't accepting it. I have restarted IIS many many time and even restarted the computer.

So my question is "Is the problem IIS or a domain issue?" If it's either one how do I fix it?

This is the ASP.NET forum. Is that what you're asking about? If not, I can move the thread to the ASP forum, just let me know.

ASP.NET and IIS can get into problems based on which was installed first. This may seem like overkill, but the best catchall solution is to uninstall VS.NET and IIS, and then reinstall 1st IIS, and 2nd VS.NET.

I am not for sure sir. When I meant asp I mean asp.net I am trying to get running.

Also to I have a question to your advice. On the windows 2k3 I have production sql server 2005 and IIS. On my computer I have the VS 2005. Sure there is a stripped down version of VS for Businuess Intellignece and what not,.

So I have to uninstall my sql server, iis and then on my computer uninstall VS on my computer. Then do an install of it all in order.

If this is what you meant I will go ahead and do this. Just making sure you realized that the IIS and the VS is on two different computers.

Also about moving this thread I do not mind at all, which ever you think best. Also thanks for your reply.

My experience was on a development machine, where I installed VS.NET. Later, I installed IIS, and things never worked correctly. I searched MSDN, and saw that this was a common problem, and then had a "fix" script, which didn't work.

So, uninstalling both, then re-installing IIS and VS.NET after, solved my problem.

That may not help you, if IIS and VS.NET are on two separate machines.

However, a clean re-install might not be a bad idea.

Have you verified that the Server is running in ASP.NET 2.0 code level? This is a problem if you are running a 2.0 application in 1.1 code level, and vice versa.

Just another thing to check.

Well see I have been taken some of my MCAD classes and this was my first time setting up IIS on the machine I was doing it on. So I wasn't changing versions of .Net without changing the code.


I belive I have found my answer to my problem. Doing much more extensive internet search I cam accross this website which was nothing but IIS.

I started reading and I fell in this criteria.
My machine was w2k3, was part of a domain, was not a domain controller.

What happens is when it's not the DC the anomonoyous (can't spell) user account get all jacked with. So just created another user and added the right permissions and presto, I get an error that says can't do directory browsing. So yeah after I fixed that I was in the clear.
Thanks guys for you input. Your kindness keep this community alive!

This question has already been answered. Start a new discussion instead.