Below Code is not working. it is not displaying any thing on web browser
can any one help me out?

css file code:
car_catlog
{
    background-color:#FF0000;
    width:100%;
    background-image:url(car1.jpg);
}
car
{
    display:block;
    border:solid;
    color:#FFF;
    margin-left: 10pt;
}
make,model,year,color,engine{
    display:block;
    margin-left: 10pt;
}
number_of_doors,transmission_type,accessories
{
    display:block;
    margin-left: 30pt;
}


XML FILE CODE:
<?xml version="1.0" encoding ="utf-8"?>
<?xml-stylesheet type= "text/css" href= "cars_catalog.css" ?>
<!DOCTYPE car
[
    <!ELEMENT car_catalog (car)>
    <!ELEMENT car (make, model, year, color, engine,number_of_doors, transmission_type, accessories)>
    <!ELEMENT make (#PCDATA)>
    <!ELEMENT model (#PCDATA)>
    <!ELEMENT year (#PCDATA)>
    <!ELEMENT color (#PCDATA)>
    <!ELEMENT engine (number_of_cylinders, fuel_system)>
    <!ELEMENT number_of_doors (#PCDATA)>
    <!ELEMENT transmission_type (#PCDATA)>
    <!ELEMENT accessories (#PCDATA)>

    <!ATTLIST accessories radio CDATA #REQUIRED>
    <!ATTLIST accessories air_conditioning CDATA #REQUIRED>
    <!ATTLIST accessories power_windows CDATA #REQUIRED>
    <!ATTLIST accessories power_steering CDATA #REQUIRED>
    <!ATTLIST accessories air_suspension_brakes CDATA #REQUIRED>        

    <!ENTITY m "Maruti" >
    <!ENTITY h "Hyundai" >
    <!ENTITY c "Chevrolet" >
    <!ENTITY f "Ford" >
    <!ENTITY MER "Mercedies" >
    <!ENTITY vw "Vokswagan" >
    <!ENTITY H "Honda" >
    <!ENTITY n "Nisson" >
    <!ENTITY t "Toyota" >
    <!ENTITY l "Logan" >
]>
<car_catalog>
    <car>
        <make>&m;</make>
        <model>SX4</model>
        <year>2010</year>
        <color>black,white,red</color>
        <engine>3 Cylinders and Fuel type: Petrol</engine>
        <number_of_doors>4</number_of_doors>
        <transmission_type>Manual</transmission_type>
        <accessories>radio,air_conditioning,power_windows,power_steering,air_suspension_brakes</accessories>
    </car>
</car_catalog>