I am setting up a wordpress page on an ubuntu server with Apache/2.4.6 (Ubuntu).

Here is what I did:

  1. I enabled rewrite mod with
    : a2enmod rewrite
  2. Changed "AllowOverride None" to "AllowOverride All" in apache2.conf
    :vi /etc/apache2/apache2.conf

    <Directory />
    Options FollowSymLinks
    AllowOverride All
    Require all denied
    </Directory>

    <Directory /usr/share>
    AllowOverride All
    Require all granted
    </Directory>

    <Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
    </Directory>

  3. Restarted apache2 server
    : sudo service apache2 restart

But I am still getting 404 error on my perma link wordpress page..

What Am I missing?

Recommended Answers

Can you post the content of your htaccess file

Jump to Post

All 2 Replies

Can you post the content of your htaccess file

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.