0

Basically, the following code doesn't work:

     <link rel="stylesheet" href="https://fiftyallstars.com/Code/font-awesome-4.6.3/css/font-awesome.css">

    <i class="fa fa-500px fa-pull-left" title="500px"></i>
    <i class="fa fa-adjust fa-pull-left" title="adjust"></i>
    <i class="fa fa-adn fa-pull-left" title="adn"></i>

And my old code on Dropbox does work:

 <link rel="stylesheet" href="https://dl.dropboxusercontent.com/u/5739741/OMAR/code/font-awesome-4.6.3/css/font-awesome.css">

<i class="fa fa-500px fa-pull-left" title="500px"></i>
<i class="fa fa-adjust fa-pull-left" title="adjust"></i>
<i class="fa fa-adn fa-pull-left" title="adn"></i>

They're exactly the same, and my folders are nested exactly the same. I've toyed with the permission settings on Filezilla (hosted by GoDaddy), I've also tried replacing the ".." instances with both the corresponding pathway on filezilla and with the original ones on Dropbox. Here's the page I'm working with, btw: http://www.50allstars.com/p/elite-teams.html

I've never used FTP before, but I'm trying to make the switch since Dropbox has informed me they'll no longer be allowing a public folder starting next Fall. I've gotten all my image links and some simpler css code to work properly, but this seems to be my one hangup.

Any help would be great. Thank you.

2
Contributors
3
Replies
43
Views
7 Months
Discussion Span
Last Post by Jon_7
1

Have a look at the inspect code in your browser to see if the css file is actually loaded

Votes + Comments
That did help me find a difference. Thanks! One step closer
0

Searches show me that my problem is I need to add CORS (cross-origin resource sharing) support to my server. This site shows a tutorial I don't (yet) understand: http://enable-cors.org/server.html and this site has an example (that I haven't figured out yet): http://stackoverflow.com/questions/13061524/how-to-set-access-control-allow-origin-on-particular-file-web-config

<location path="Sample.txt">
    <system.webServer>
      <httpProtocol>
        <customHeaders>
          <add name="Access-Control-Allow-Origin" value="*" />
        </customHeaders>
      </httpProtocol>
    </system.webServer>
  </location>

If any of this leads to any answers that would work for me, that would be great. Thanks for the help. I'll check back in if I figure it out by myself. I'm truly appreciative of your assistance.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.