Hello,
The title pretty much describes the problem I'm having. Right now, I've got a <table> with two <tbody>s in it; the first one is visible (display:inline) and the second one is invisible (display:none). The first one contains a button, the second one several form fields. Pressing the button hides the first tbody (style.display="none") and shows the second (style.display="inline"). Filling out the form and pressing a "Save" button at the end hides the second tbody again and shows the first tbody. The trouble is, there is still some blank space left there, which accumulates each time the buttons are pressed, leaving quite a large gap. Note: this is happening in Firefox (using 1.5), it seems to be fine in IE 6. Any help would be appreciated :) Example script here: http://www.krofh.net/example.html (taken out of context of the original page it was in, but it still demonstrates the problem) Thanks,
- Jesse

Sorry, the second tbody is the rest of the table.. my bad.

This all seems over complicated, why don't you use one table... or better, no tables? Then just show and hide div elements?

Why not DIV elements? It's because I like lining my forms up in the table with left-align for the name and right-align for the fields. If you could tell me a way to do that with DIVs, that'd be great.
Also, I just made a few changes, because there were a few tags that had gotten lost when I pulled that bit of code out to work just on that... but it still hasn't fixed it. :-/ I ran it through the w3 validator, and there aren't any tags missing or anything wrong with it, so... not sure what's causing the trouble.

Arrr! I have solved the problem, using your suggestion of DIVs. I'm still using lots of tables; part of the excessive table pieces is me trying to work with the typical vBulletin system layout, I'm writing a vB hack... but also, when it parses the templates, it has a tendency to add things like extra <tbody>s in there that I don't really need. Anywho, it's working now, thanks for the suggestion.

This article has been dead for over six months. Start a new discussion instead.