First: If this is in the wrong forum, I apologize. My question is more concerned with figuring out the correct configuration with the Apache2 web server than with anything dealing particularly with PHP. I simply did not see an appropriate forum for this type of topic. If such a forum exists, would a moderator please move this thread into it?


I have been, for the past two weeks or so, attempting to upgrade a computer from php 4.3.4 to php 5.1.6. I have tracked down all of the files I thought I would need to modify. However, I have obviously missed something somewhere- when I try to run the phpinfo() command, the resulting information indicates that I'm still running php 4.3.4.

For the record, I am attempting to install/upgrade on a system running SuSE 9 linux. I believe it is SuSE 9.3, but I am not completely certain of that. I am also attempting to do this remotely, so I am afraid that solutions involving direct access to the machine are not a viable option for me.

I have sought aid for this in various places, and the assistance I have received at another computer help forum included a statement that, based on the results of the phpinfo command, the apache2 server was not drawing from the newly-created php 5.1.6 install, but instead still drawing from the older 4.3.4 installation.

I am very new to such installations; this is my first attempt at doing so. I have, at the moment, only a vague notion what I should be looking for, and am getting quickly confused as to what file or files I should be trying to modify to get apache2 to use my 5.1.6 installation of php. I have tried looking over various .conf files in the apache2 directory on my system, but without knowing what I'm looking for, I could easily have glanced over it without recognizing it.

If anyone out there is willing to offer some useful suggestions as to what files I should be looking for or at, I would be very grateful.


Thank you for your consideration,
EnderX

A much more knowledgeable aquaintence recommended that I use the command 'rpm -e apache2-mod_php4' to remove the old setup. I did so. Now, however, either php or apache2 one seems to have been messed up. When attempting to open a .php page, my system no longer seems to recognize it as a valid extension, instead popping up a prompt asking what it should be opened with. I know that the httpd.conf file contains a command 'AddType application/x-httpd-php .php .phtml' which should be telling it, if I understood the installation instructions correctly, to recognize those extensions. Can anyone suggest a reason it might not be doing so?

Thanks in advance,
-EnderX

Perhaps the php5 module is not loading correctly? You might want to check in the module-loading section of httpd.conf to make sure that the LoadModule line for php is there. Then try restarting Apache a few times.

And when Apache 2 starts, there shouldn't be any errors. If there are any, this could point to some potential problems.

Does this help any? I mucked with the system a bit yesterday, and tried a reconfigure using the original set of instructions. Still no luck getting everything to run; I can see phpinfo or echo commands, but not if anything else is in front of them. This is the contents of the error_log file after the most recent restart:

"[Tue Nov 07 14:58:20 2006] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Tue Nov 07 14:58:20 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Tue Nov 07 14:58:20 2006] [warn] module php5_module is already loaded, skipping
[Tue Nov 07 14:58:20 2006] [notice] Apache/2.0.49 (Linux/SuSE) configured -- resuming normal operations"

Any suggestions, of should I start digging further back in my error records?

This article has been dead for over six months. Start a new discussion instead.