Hi,
my asp.net app runs on my laptop but when i put it on my webserver, the aspx pages won't load. I'm a pro VB programmer, both computers are on win2000 pro. it says: error in "/" application. I think the code is ok, no trace or debug problems, so it's iis or what?

I'm not familiar with pws, do i have to do special setups or should i just put win2000server on the webserver?

I'm thinking of running a webserver with a static IP as I have to update databases daily, would I still be better off to use a web hoster?

thanks, tommi

Did you type the URL directly in? For example www.mywebserver.com/index.aspx if that works, then the reason you aren't seeing your page by just typing www.mywebserver.com is because the page name hasn't been added in in IIS. Go into IIS, locate your website, right-click, go to properties click on the documents tab go to add and add your document "*mypage*.aspx". If this doesn't solve the problem, could you please go through the steps you did in order to publish the site on your web server, usually, you just:

go to Project>copy project
type in your url for your web server
Use frontpage web access method
Copy only the project files needed to run this application

if that doesn't work, could you please explain what method you used in publishing and the exact error.

Hope I helped

Slade

When you put it on your webserver, did you just copy the files over?

Is .NET Framwork installed on the webserver?

If so, you have create a Virtual Directory in IIS that matches the directory you placed those files in. Asssuming not right into the wwwroot folder.

Slade is correct in asking how did you publish, create or otherwise generate these aspx pages?

We need to know a little more to fully answer your question.

Thanks ALOT for the info. I just copied the aspx pages into a folder I created in c:\inetpub\wwwroot, then created a virtual directory which I'm using in the URL (the URL uses a static IP at this time, no domain yet). So I didn't add the pages in iis or "publish" the site as I would with a frontpage created site. I assumed anything in the virtual directory would be available. I will try the things you have suggested and report back.
tommi

Hi,
.net framework is installed. I used notepad or asp.net Web Matrix to write the .aspx pages. I created a virtual directory which points to the folder where I simply copied the pages (and added a bin folder).

I can use the browser to view htm or asp pages via http://webserver/index.htm for example, or use my static ip to view as in http://xx.xx.xx.xx/index.htm or access a virtual directory in both ways (webserver or static ip) such as http://xx.xx.xx.xx/vd/index.htm.

I can add a default document to iis properties, such as index.htm and have it come up.

but aspx pages don't come up.

as far as Project> copy with FP web access method, what software is that in? I'm not using that, should I be using it? Can you create aspx pages in FP or would that be InterDev you are referring to?

could you please turn custom errors off in the web.config and I'll have a proper look at the error.

hadn't created a web.config
but did and set custom errors mode=off

thanks, tommi

Tommi - Just curious, but you mentioned that you used the ASP Web Matrix to create the ASP pages, did you run them from that program as well? The reason I ask is that Web Matrix will create an "on-the-fly" Virtual Root with the port set to 8080. Could you try this and see what the result is, if you haven't already.??

And also give check the following (see attached pic) to verify that aspx is a listed document, and stop & restart IIS.

Hi Paladine,
yes the default.aspx is listed in properties/documents as shown.

aspx pages load ok with web matrix, so web matrix loads index.aspx page on the fly using port 8080 to browser.

also, on other computers (my laptop), i can view these aspx pages in browser. so I'm wondering if it's something with my windows or iis setup or net framework issue on my webserver, as only aspx pages won't load.

on website properties/home directory/ settings-app mappings, aspx is listed with executable path to my .net framework location- but I always get "compilation error", code 128 when loading an aspx page.

thanks, tommi

Ok, well I did some looking into this error, and it seems to be a random occurring error, with no reason.

I would re-install .NET Framework, and see what happens. I use to get this same error on my Windows 2003 Server, but with a reinstall it cleared right up. Not such an easy task I know.

One other suggestion is to post this error message at ASP.Net Forums as those folks have a ton of experience on .NET. I search the forums already with not results on that error message.

Sorry dude, wish I could help more.

thanks, I will re-install. If that doesn't work I will switch the computer from win2000pro to win2003server, something that sounds like loads of fun.

I have an open thread on asp.net, this problems is sometimes fixed by running aspnet_regiis.exe -i from the version directory, but not in my case.

There are other threads on asp.net under different forums, no one has a solution.
for future searchers, this is compilation error code 128.

I upgraded to win2003 server (there goes the day!), running .net framework 1.1 (loaded today) and still get the same problem even with a new page created with web matrix with no content. I will say that win2003server is very cool- though very complex. I do not have the indexing server enabled, all the rest are..should I have it enabled?

with win2003server, we get LOTS of details, all users are allowed in the file's properties, here is the error:

Access to the path "C:\WINNT\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files\root\2135a508\8d69a834" is denied.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.UnauthorizedAccessException: Access to the path "C:\WINNT\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files\root\2135a508\8d69a834" is denied.

ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS 5 or Network Service on IIS 6) that is used if the application is not impersonating. If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user.

To grant ASP.NET write access to a file, right-click the file in Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[UnauthorizedAccessException: Access to the path "C:\WINNT\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files\root\2135a508\8d69a834" is denied.]
System.IO.__Error.WinIOError(Int32 errorCode, String str) +393
System.IO.Directory.InternalCreateDirectory(String fullPath, String path) +632
System.IO.Directory.CreateDirectory(String path) +195
System.Web.Compilation.PreservedAssemblyEntry.DoFirstTimeInit(HttpContext context) +85
System.Web.Compilation.PreservedAssemblyEntry.EnsureFirstTimeInit(HttpContext context) +97
System.Web.Compilation.PreservedAssemblyEntry.GetPreservedAssemblyEntry(HttpContext context, String virtualPath, Boolean fApplicationFile) +29
System.Web.UI.TemplateParser.GetParserCacheItemFromPreservedCompilation() +91
System.Web.UI.TemplateParser.GetParserCacheItemInternal(Boolean fCreateIfNotFound) +148
System.Web.UI.TemplateParser.GetParserCacheItemWithNewConfigPath() +125
System.Web.UI.TemplateParser.GetParserCacheItem() +88
System.Web.UI.TemplateControlParser.CompileAndGetParserCacheItem(String virtualPath, String inputFile, HttpContext context) +120
System.Web.UI.TemplateControlParser.GetCompiledInstance(String virtualPath, String inputFile, HttpContext context) +36
System.Web.UI.PageParser.GetCompiledPageInstanceInternal(String virtualPath, String inputFile, HttpContext context) +43
System.Web.UI.PageHandlerFactory.GetHandler(HttpContext context, String requestType, String url, String path) +44
System.Web.HttpApplication.MapHttpHandler(HttpContext context, String requestType, String path, String pathTranslated, Boolean useAppConfig) +699
System.Web.MapHandlerExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute() +95
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +173


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:1.1.4322.573; ASP.NET Version:1.1.4322.573

Access to the path "C:\WINNT\Microsoft.NET\Framework\v1.1.4322\Temporary ASP.NET Files\root\2135a508\8d69a834" is denied.

Thats your answer. Give the user "NT Authority\Network Service" full administrative rights to the folder: C:\WINNT\Microsoft.NET\Framework\v1.1.4322\ (and all the subfolders).

Thanks, but I don't see such a user on the Active Directory Users list and when I try to add it to the security of the folder, it says no such user. How does this work?

I investigated and the Network Service account has the same permissions as the Users account, so I just added that to the WINNT security-users list and it works. I've spent a few days with this problem... Tekmaven, thank you so much! The solution for this problem is permissions.

Thanks, guys,
but I still have this question which will be of help to anyone who has this problem in the future- how do I grant permissions to the Network Services Account, it is not a user account and so I can't add Network Services as a "user account" to the the folder(right click) /sharing and security/security-users.

As Network Services Account defaults to Users permissions, I added Users to the folder security and that worked.

thanks again, tommi

Thanks, guys,
but I still have this question which will be of help to anyone who has this problem in the future- how do I grant permissions to the Network Services Account, it is not a user account and so I can't add Network Services as a "user account" to the the folder(right click) /sharing and security/security-users.

As Network Services Account defaults to Users permissions, I added Users to the folder security and that worked.

thanks again, tommi

Well, the "Network Services" account would only be for Windows Server 2003. In Windows 2000/XP, its the MACHINENAME\ASPNET account that would need full privlidges to that folder.

Edit: I just realized your using Server 2003. The only explination I can give you is that because you upgraded from Windows 2000 (and didn't do a clean install), you are still using the ASPNET account. I'd be interested to know if that account is still on your machine.

Comments
good ol' tekmaven
This article has been dead for over six months. Start a new discussion instead.