I can recieve data into my .asp pages from my access database but when I try to write to the db I get the following errormessage

:


HTTP 500.100 - Internal Server Error - ASP error
Internet Information Services

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Error Type:
ADODB.Recordset (0x800A0BB9)
Arguments are of the wrong type, are out of acceptable range, or are in conflict with one another.
/NewMembResp.asp, line 11


This must a common problem. Any advice much appreciated

Chris, I'd need to see the code segment (line 11 - /NewMembResp.asp) or similar code segment that is generating this error.

Some quick thoughts: make sure the data types of the fields in your database tables match the data types of the values you're trying to write to the corresponding fields in the table(s). Also, make sure that the table and field names you are referencing in your source code exactly match those in your database.


I can recieve data into my .asp pages from my access database but when I try to write to the db I get the following errormessage

:


HTTP 500.100 - Internal Server Error - ASP error
Internet Information Services

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Error Type:
ADODB.Recordset (0x800A0BB9)
Arguments are of the wrong type, are out of acceptable range, or are in conflict with one another.
/NewMembResp.asp, line 11


This must a common problem. Any advice much appreciated

I think if you posted the fields in your DB, along with their TYPE and your ASP code, we'll wrap this up in no time.

Chris, I'd need to see the code segment (line 11 - /NewMembResp.asp) or similar code segment that is generating this error.

Some quick thoughts: make sure the data types of the fields in your database tables match the data types of the values you're trying to write to the corresponding fields in the table(s). Also, make sure that the table and field names you are referencing in your source code exactly match those in your database.

Problem fixed. It was caused by permissions in IUSR set to read only Thanks anyway

Thats a weird error to get for a permissions error... normally the error you get is this:-
Microsoft JET Database Engine (0x80040E09)
Cannot update. Database or object is read-only
OR
Microsoft OLE DB Provider for ODBC Drivers error '80004005'
[Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x6f8 Thread 0x5ec DBC 0x224603c Jet'.
OR most commonly:
[Microsoft][ODBC Microsoft Access Driver] Operation must use an updateable query.

I'll add your one to memory for future puzzlement.

Problem fixed. It was caused by permissions in IUSR set to read only Thanks anyway

Chris, how did you change your permissions. My OS is Windows 2000 Professional. thank you for your time, the error I got is located below.

Here is the error I got:

The page cannot be displayed
There is a problem with the page you are trying to reach and it cannot be displayed.

--------------------------------------------------------------------------------

Please try the following:

Click the Refresh button, or try again later.

Open the localhost: home page, and then look for links to the information you want.
HTTP 500.100 - Internal Server Error - ASP error
Internet Information Services

--------------------------------------------------------------------------------

Technical Information (for support personnel)

Error Type:
Provider (0x80004005)
Unspecified error
/urmc/deleteEvent.asp, line 9


Browser Type:
Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)

Page:
POST 57 bytes to /urmc/deleteEvent.asp

POST Data:
DeleteEvent=24&DeleteEvent=23&DeleteEvent=20&Process=True

Time:
Tuesday, November 16, 2004, 3:25:33 PM


More information:
Microsoft Support

To change permissions on a folder/file open explorer and navigate to the folder/file. Right Click and select Properties, then open the Security tab. Check in the Group or User Names window for Internet Guest Account. If it is there then select it and in the Permissions window select the Read and Execute, Read, Write boxes. If the Internet Guest Account isn't in the User Names window you will need to Add it. Select Add and enter IUSR_computername in the Object Name area. Make sure to replace computername with the name of your computer. Set the permissions and Apply.

This article has been dead for over six months. Start a new discussion instead.