Hello all,

I have a problem and after searching for hours was hoping someone would have some information that would greatly help me out.

I am developing a website locally on my development machine, (Mac OS X Tiger 10.4.11, Apache 1.3.33, and PHP 5.2.2). The site is based on a CSS layout, and I am using PHP Includes in a template to pull in the following files, header.php, content.php, and footer.php. After fighting for hours with it locally on my development machine i decided for giggles to upload it to my production server and see if it worked there. My production server is a Windows 2003 box with php 5.2.2 and IIS 6.0, and it works on the production server with no issues.

My problem is that on the Mac when I go to view the files in a browser using localhost the content of the page displays, but it does not display the CSS attributes or the include files. I can see the nav but it is a unordered list rather than being controlled by the CSS.

I have verified that Apache and PHP are working on the Mac as I have developed other web apps on the same machine and they work flawlessly, even ones that I am using MySQL as the DB. Everything appears to be working correctly on the Mac but this site and the php includes. To me it appears to be an Apache issue, due to it does work correctly on the Win2k3 box running IIS and PHP but I really don't have a clue at this point.

Sorry for the lengthy post.

Best Regards, Gym

Can you access the CSS file if you type the URL directly into your mac's web browser? If you can, and the path that you have specified in the <link rel="stylesheet"... line is correct, then the issue is related to your Mac's browser application.

Thanks for the clue, as it turned out I could not access the CSS file. When I tried to browse to it I would get a 403 Forbidden error. Last night I thought it could possibly be a file permissions issue, but due to working on a small screen and having all the options expanded I did not see the "Apply to all" button located at the bottom of the screen. Sometimes you just need to walk away, clear the noggin and try again later. LOL I feel like such a schmooo!

Great site by the way, and thanks for the assistance.

Gym

This article has been dead for over six months. Start a new discussion instead.