Hi I have a dell latitude D820 notepad. My son thinks he is a computer wizz kid, messed about with the windows and bios passwords. when the laptop is booted up it is asking me for the bios password. Because he has tried to enter passwords in a number of times It will not let me press F2 to get to the bios settings. I have tried to put in my XP disc and over wite but the boot up hits this password first and thats as far as it goes. I have took the thing to bits took the watch cell battery out and shorted it, cannot find any jumpers on the motherboard, does a laptop have them? Tried to boot it back up and still the same. Spoke to Dell but the warrenty does not include what my soon has done.
Is the next thing a new motherboard?
Thanks in advance for you help and surgestions.

You could try opening up the computer and removing and putting back the cmos battery on your motherboard.

If you have exhausted . . . obtain a "boot and nuke" fdd or cdd. Put the disk in and power up. Key autonuke at the splash and press enter. In an hour or so, you will have an empty hdd. No password, no os, no data, no partition, nothing. Load it up with your favorites.

its a bios problem so that obviously wont work.

Really, the boot and nuke is exactly that. It will boot - guaranteed and it will nuke - no prob. Precisely how it works takes a long explanation. It does not care at all about the bios, it just boots and nukes.

Once you wipe the hdd, you will want bios D820_A07 from dell.com dated 6/26/07.

how can i remove bios password for dell latitude d820