0

Hello all,

I have a problem that I hope some one can assist me with. I have a site done in html and css that also has swf files embedded. It works great on Internet Explorer, but Firefox is another story. The swf file is a page flipper and in firefox the pages takes turns working. A page that works on one visit will not work on another visit, but all work fine in Internet Explorer.

I have all of the necessary plugins for firefox and have used both embed and object tags for the swf files. I am not sure what else the problem could be.

Any solutions would be great.

Thanks,

KimJack

4
Contributors
4
Replies
8
Views
9 Years
Discussion Span
Last Post by steve136
0

Here is the code which is in a table. Any help will be appreciated.

<table width="92%" border="0">
                     <tr>
                        <td width="61%" bgcolor="#FFFFFF"><script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','width','600','height','400','src','SimonGirtyTab/GirtyFlipper','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','movie','Simon/Simon' ); //end AC code
                        </script>
                           <noscript>
                           <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="600" height="400">
                              <param name="movie" value="Simon/Simon.swf" />
                              <param name="quality" value="high" />
                              <embed src="SimonGirtyTab/GirtyFlipper.swf" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" width="600" height="400"></embed>
                           </object>
                           </noscript></td>
                        <td width="7%" bordercolor="#000000">&nbsp;</td>
                        <td width="32%" align="left" valign="top" bordercolor="#000000"><p align="center" class="style12">&nbsp;</p></td>
                     </tr>
                  </table>
0

use this Code instead flash file in html file

<OBJECT CLASSID="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" CODEBASE="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" WIDTH="399" HEIGHT="104">
     <PARAM NAME="movie" VALUE="SimonGirtyTab/GirtyFlipper.swf">
     <PARAM NAME="quality" VALUE="high">
     <EMBED SRC="SimonGirtyTab/GirtyFlipper.swf" QUALITY="high" PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer" TYPE="application/x-shockwave-flash" WIDTH="399" HEIGHT="104"></EMBED>
	 </OBJECT>
0

There are a couple of ways you can correct this. However rather than giving you the code, there is a very useful site that I use sometimes that will generate the code for you just from putting the file name and location in. I have tested these across IE and firefox and dont seem to get any problems. If you are using dreamweaver, do not use the insert option from there as it rarely works. the site is http://www.swffix.org/swfobject/generator/

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.