0

I ran into this issue recently. Thought I would share the resolution.

Folder is not accessible. Access is denied
\Documents and Settings\[any username]\[Any Foder] is not accessible. Access is denied
C:\Documents and Settings\All Users\Documents is not accessible. Access is denied
d:\ is not accessible. Access is denied


Gaining access to your data depends on which version of XP you are on.
It is easier if you are running XP Pro, but can be done in XP Home also.
No need to reinvent the wheel, so we'll use the Resolution info on this Microsoft page.

http://support.microsoft.com/kb/810881
To resolve this issue, you must turn off Simple File Sharing, and then take ownership of the folder:
1. Turn off Simple File Sharing:
a. Click Start, and then click My Computer.
b. On the Tools menu, click Folder Options, and then click the View tab.
c. Under Advanced Settings , click to clear the Use simple file sharing (Recommended) check box, and then click OK.
2. Right-click the folder that you want to take ownership of, and then click Properties.
3. Click the Security tab, and then click OK on the Security message, if one appears.
4. Click Advanced, and then click the Owner tab.
5. In the Name list, click your user name, Administrator if you are logged in as Administrator, or click the Administrators group.

If you want to take ownership of the contents of that folder, click to select the Replace owner on subcontainers and objects check box.
6. Click OK.

You may receive the following error message, where Folder is the name of the folder that you want to take ownership of:
You do not have permission to read the contents of directory Folder. Do you want to replace the directory permissions with permissions granting you Full Control? All permissions will be replaced if you press Yes.
7. Click Yes.
8. Click OK, and then reapply the permissions and security settings that you want for the folder and the folder contents.

If you are running XP Home it is a bit more difficult.
You have to boot into SAFE MODE by pressing F8 while the computer boots, then log onto an administrator account.

Once you are logged on you can follow the same Microsoft page instructions listed above.
(Just skip the part about turning off "simple file sharing")

You can change ownership to be just your administrator account or to the Administrator Group, so all admin accounts will have access to the data.

I ran into this issue while clearing viruses off someone else's boot drive.
I mounted the XP Home drive in my XP Pro system to scan for viruses.
The AV software could find and identify the viruses, but could not remove them because of the ownership on the folders.
I had to gain ownership of the folders using the XP Pro method to remove the infected files. That was fairly easy.
However, when I put the XP Home drive back into its case, those folders were not accessible. Neither were any folders create on the drive by the XP Pro system.
After researching the issue, I found I had to boot into safe mode (press F8 while booting).
Once logged onto an administrator account in safe mode, I was able to change the folder ownership to the original administrator account.
I decided to change the ownership to the Administrator Group, so the data can be access by any administrator. (I didn't know how much work I might have left to do).
I did not do it, but I suspect I could have changed the permissions to any user name on the system, not just administrators, by adding that user to the list. And enabling Full permissions.

I hope this information helps someone resolve this issue without too much difficulty.

isrjs

2
Contributors
2
Replies
4
Views
9 Years
Discussion Span
Last Post by isrjs
0

FYI:
You can change ownership on multiple files or folders just by selecting them before starting this procedure.
I tried doing an entire drive, and it worked for the most part, but there were a few files I had to do individually.

For some folders & files it is enough to add your user name on the security tab, and check ALLOW FULL CONTROL, to gain access.
You'll know if you can do it, if the ADD button is active (clickable).
If it is not active, then you will have to use the ADVANCED option to "replace ownership" as detailed in the above post.

Hope you this post was useful to you.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.