0

Hey all,

My Windows Security Alerts keeps on telling me that I haven't turned my Automatic Updates on. So I try to turn it on but it won't let me, and going to Control Panel doesn't help either.

So I went to the Microsoft website and it told me to go to services.msc and fix it there? Well I did: open up Automatic Updates and turn the Startup Type to Automatic, and Service Status to Start.

But when I do that a pop-up dialog comes up saying "Error 1058: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it"

What do I do?! Thanks for your help in advance!

2
Contributors
1
Reply
2
Views
9 Years
Discussion Span
Last Post by jholland1964
0

Please check the following are started:

1.Automatic Updates
2.Background Intelligent Transfer Service (BITS)
3.Cryptographic Services
4.Remote Procedure Call (RPC)
5.System Restore Service

To verify that BITS is correctly configured :

1.Double-click `Background Intelligent Transfer Service.`

2.In the Startup type box, click Manual, and then Apply.

3. Click the `Log On` tab, and then verify that the service is enabled in
every hardware profile that you have listed.

If the service is disabled in one or more hardware profiles, click the
hardware profile, Enable, and then Apply.

4. Click the General tab and then Start.

If BITS starts successfully, visit the Windows Update Web site or the
Microsoft Update Web site to see if you can obtain updates. If it works OK,
change (2.) to automatic
-
If you still receive the same errors, verify that you have correctly
performed steps 1 through 5.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.