Hey guys since 2 days i've been getting the above error on my Windows media player 10. I tried un-installing and re-installing it but that didn't work. I tried deleting all files from the c>programs file>windows media player folder but that also did not work.

I then thought that probably I might need to update windows so I went to Start>Programs>Window updates. This opened Internet explorer but the page goes blank. I tried copy-pasting it to opera but it tells me to goto Start>Help and Support to update it. I tried that but Help and Support won't open as well. Just for the record, Start>Search is also not working. The page opens , but the box where you fill the letters to search a file is blank. I tried taking some screenshots later but PAINT is not there in Start>Accessories.

I was also advised to do system restore but that is also not opening.

A night before this happened I got Norton Anti Virus 2003 saying that an internet program error has occured so it asked me to un-install and re-install it again. I have misplaced the cd so I instead downloaded AVG and scanned my computer later for viruses. Around 30 objects were infected and I was told that these are mainly adware so I installed Spyware blaster. Since then i've been getting these problems.

Is this all linked?Just for the record ,Everything is running very smoothly i.e.opera,winamp,a few games I have installed-EVERYTHING except all these above mentioned window components. Please help me and don't advise me to re-install Windows Xp(PRO) because I don't know how to and even once I do re-install windows I would have install plenty of drivers which I don't know how to do. It doesn't matter how complicated your solution is but unless it's not re-installing my windows i'm ready to do ANYTHING.

Help would be appreciated.

Internet Explorer is the only browser you can use to get Windows Updates (as far as I know).

Getting the updates may fix your problem with WMP.

Run these free online scans to see if they find anything else:
http://www.pandasoftware.com/active...n_principal.htm
http://www.trendmicro.com/en/home/us/enterprise.htm
http://www.ravantivirus.com/scan/indexie.php

Go to this thread and follow the other recommendations:
http://www.daniweb.com/techtalkforums/thread5690.html
Then post a hijackthis log here; hopefully we can figure out why IE isn't working.

try running the winsockfix in my sig. as well as adaware.

try running the winsockfix in my sig. as well as adaware.

Both links say it was not found on the server.

I tried that right now ... didn't work :(

What didn't work, the links or the fix?

....my bad, the website (majorgeeks) i was using keeps resetting the link or something i changed the sources of my links try them now. Other wise just search for winsockfix in google