0

I also have this problem (since 7.10), and would hugely appreciate your help. I am using ASUS laptop with 2Gb RAM and 2.0GHz Intel Core2Duo processor. I can't say anything about 7.04, because this is a new laptop, and the first Ubuntu version installed was 7.10. By the way, the laptop had Vista Business pre-installed, and the sound was fine there. It was also fine on XP after I downloaded appropriate Realtek driver.

I downloaded source and built ALSA 1.16 under 7.10 (as described in multiple forums), but with no improvement. As far as I know, this is the latest version of ALSA, and it is built in 8.04, so no more build can help.

I played with various options in /etc/modprobe.d/alsa-base as well (as this was advised in various forums), but with the same outcome. Literally, nothing helps so far.

Maybe I am missing ticking/unticking some option?

$ cat /proc/asound/card0/codec#* | grep Codec
Codec: Realtek ALC660-VD
Codec: Motorola Si3054

And here is the output of 'lsmod | grep snd' :

snd_hda_intel 344728 3
snd_pcm_oss 42144 0
snd_mixer_oss 17920 1 snd_pcm_oss
snd_pcm 78596 2 snd_hda_intel,snd_pcm_oss
snd_page_alloc 11400 2 snd_hda_intel,snd_pcm
snd_hwdep 10500 1 snd_hda_intel
snd_seq_dummy 4868 0
snd_seq_oss 35584 0
snd_seq_midi 9376 0
snd_rawmidi 25760 1 snd_seq_midi
snd_seq_midi_event 8320 2 snd_seq_oss,snd_seq_midi
snd_seq 54224 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 24836 2 snd_pcm,snd_seq
snd_seq_device 9612 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 56996 17 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_hwdep,snd_seq_dummy,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore 8800 1 snd

3
Contributors
10
Replies
11
Views
9 Years
Discussion Span
Last Post by mosgjig
0

Here is one more command and its output:

$ lspci | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

0

I am sorry for flooding the thread with my posts, but I wanted to add, that I definitely unmuted all channels shown in Volume Control (as far as I understand, this should be similar to doing that via alsamixer console application). I also played with the deliberate muting of every channel in turn (someone mentioned this solved his problem), but with no success.

Also, the version of ALSA on my laptop is 1.0.16 (I previously specified it incorrectly as 1.16).

0

try [ aplay -l ],maybe show problem..

Thanks for suggestion. No, it did not show anything specific. Still I managed to fix (searched ubuntuforums):

In Hardy (8.04) this worked for me, but did not in Gutsy (7.10):
sudo vi /etc/modprobe.d/alsa-base

Then added the following line at the end:
options snd-hda-intel model=lenovo

Also works:
options snd-hda-intel model=hp

BUT: still struggling with the microphone - does not work even in the Sound Recorder. I've got a built-in microphone and webcam at the top of the screen.

0

And yes, everything is unmuted and set to top volume (alsamixer).

0

Was able to get recording working (but playback at lower volume): changed input source from Front Mic to ATAPI Mic (in alsamixer or Volume Control).

BUT: Test call fails in Skype (do not hear my voice palyed back). Skype suggests using OSS rather than ALSA or ALSA emulator for OSS. All I did was changing in System | Preferences | Sound | Sound capture to 'OSS - Open Sound System'. Maybe, more detailed changes required.

0

Final blow:

To make Skype working (with good playback from microphone recording) you should install alsa-oss package, then change command from skype to aoss skype

That's it.

0

I plased the string you mentioned in alsa-base however my headphones do not work. neither headphones nor speakers.

I have the same output as you with the commands you posted.

I am running 8.04 64 on ASUS M51SN - x2 , any suggestions?

I tried to test the mic too, but to no avail. Can't do skype since they don't support 64.

0

I plased the string you mentioned in alsa-base however my headphones do not work. neither headphones nor speakers.

I have the same output as you with the commands you posted.

I am running 8.04 64 on ASUS M51SN - x2 , any suggestions?

I tried to test the mic too, but to no avail. Can't do skype since they don't support 64.

First of all, you mentioned that Skype does not support 64, which as I understand, means you are running 64-bit version of Ubuntu. I can't comment on that, because I installed 32-bit version (being aware of multiple driver-related issues on 64-bit version).

With sound and speakers, it could be that when you record your voice it is palyed back at the very low volume, so try be as close to microphone as possible, then listen carefully,

Unfortunately, I can't suggest anything particular in your case, because I am not an expert in hardware - I just tried to describe what worked for me with the maximum details.

As far as I understand, the most likely solution will be to find out the right value of 'model' option to get sound out (although it did not work for me with the older version of Ubuntu), then to play with alsamixer to make microphones working (unmuting some channels and possibly muting others).

Also, I can tell that my laptop model is F3Sc (you can see the model underneath your laptop), but one of my friends has Gentoo and experienced the same problem (it is related to Intel HDA system rather than Linux distro). He fixed his troubles by playing with the 'model' setting too ('lenovo' was the one which worked for him).

0

Thnx for the quick response!

After further digging i came across a reasonable solution which got my headphone jack to work, though not with much quality, sound shifts between left and right sometimes. Have not tried the mic yet. The lines i placed in alsa-base were

options snd-hda-intel enable=1 index=0 model=lenovo
alias snd-card-0 snd-hda-intel

also found the following forum for my laptop, surprised that it took 3 hrs of googling to get to it.
http://ubuntuforums.org/showthread.php?t=753679

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.