0

hi really this issue is troubling:

I exported the database structure using the phpmyadmin as harry.sql from my local system.now I went to company server/cpanel /mysql database.created a user with username and password. I would like to import this file and I tried the same way that I used to do in local server but it says Access denied for name@localhost.com some #1044 blah blah.

I have tried with already existing users and the privileges for all the users I tried as ALL Priveleges.I am able to access the server but not able to create tables and data structure.

Earlier there was a error with 'DEFAULT CHARACTER SET latin1 COLLATE latin1_general_ci' at line which when removed started saying of access denied.

Hope you might be knowing it.


regards
Hari

2
Contributors
2
Replies
3
Views
12 Years
Discussion Span
Last Post by hbmarar
0

u import file from ur cpanel / mysql/ phpmyadmin and first u create db name than username , than put that user u created into that db and than connect via phpmyadmin and import the sql to ur db .

0

hi,

I solved this issue. It was the version differences.The collate was intorduced in mysql 4.1 and so when we create a dump file and import it to a lower version this issue comes.

SOlution: open in wordpad.search for 'collation .... ' string and replace all occurrences with ' '.

Now this file is usable.

regards
Harish

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.