0

i have ubuntu 8.10 .
how can share any folder from a drive such that every person in lan network computer can see that.
(in xp we can just share in one right click)
but how can we share in ubuntu.

please would you guide me from begining.

4
Contributors
17
Replies
19
Views
8 Years
Discussion Span
Last Post by bipinbaglung
Featured Replies
  • 1
    jbennet 1,618   8 Years Ago

    The problem is exactly as it says, you dont own the folder you are trying to share. go to the console and type "sudo nautilus" then navigate using that window to the folder, and try sharing it again. (using the sudo command will give that explorer window admin privileges) Read More

0

First, see if this hasn't been done already.
Open Network on the Ubuntu box and see if you have a share defined. If not, right-click to share a folder.
Open Network places on the XP box. Windows network. I believe Ubuntu defaults to Workgroup, and you should find your Linux share in there.
You can edit the Samba config file to change the Workgroup:
http://www.linuxquestions.org/questions/linux-networking-3/how-to-network-ubuntu-to-and-xp-network-454120/
Or, just change the XP workgroup name to "Workgroup".
This is much easier than it used to be.

0

i just want to share a folder to lan from ubuntu such that my friends in this lan can visit my shared folder

0

Did you try any of my suggestions?
They were written to be of assistance, and we won't get very far without your participation.

0

yes
when i try to share a folder "Tools" from a NTFS partition /media/Backup i get this information
'net usershare' returned error 255: net usershare add: cannot share path /media/Backup/Tools as we are restricted to only sharing directories we own.
Ask the administrator to add the line "usershare owner only = False"
to the [global] section of the smb.conf to allow this.
I had tried this by right clicking on the folder then sharing options then mark on share this folder then click on create share. aftr that i see the above information. now i think you can fix the problem

1

The problem is exactly as it says, you dont own the folder you are trying to share.

go to the console and type "sudo nautilus" then navigate using that window to the folder, and try sharing it again. (using the sudo command will give that explorer window admin privileges)

0

now i can share my folders but i cant access others shared folders. it ask for username domain and password. where username is already filled with mine domain is also filled.
now the asked password is theirs'?? and i have to get password by other medium?
again when my friend try to access my shared folders the same problem persists.
But i do not have set any password in sharing what may be the default password or from where do i have to set ?

Attachments Screenshot-Enter_Password.png 20.92 KB
0

you use their password and username for thiers, and your username and password for yours, obviously.

0

now i dont know mine password also.
Is that the administrator password or i can set other ? how can i set password?

0

In Samba, the dollar sign has special meaning (something to do with netbios and/or hidden shares). Try sharing the name on the 'doz box without a $, and try to connect to it. You MIGHT be able to escape the $ or replace it with \044 or something crazy, but you might as well just make a share without the $, and use it.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.