0

I've ventured into Linux/Ubuntu world only a week ago by installing a Ubuntu server distribution on an old PC. Trying to do simple things such as change/edit some files on the Ubuntu server using Bitvise Tunnelier SSH client with built-in GUI SFTP. Tunnelier SSH client is running on a Windows machine, SSH server is using unmodified installation configuration on the Ubuntu server; both machines are in a local LAN, no firewalls in between.

SFTP allows me to download files from the Ubuntu server to my local Windows machine, but it does not allow me uploading to the Ubuntu server, or creating a file or a folder on the remote server side. (It does allow me to change file or folder permissions, however.) So far I've tried to do this on different folders, including user's home. Tried to change permissions on folders, allowing everything (777); no luck. Thought disk space might be a problem, deleted a bunch of log and temp files, no success either. Searched, googled, read dozens of pages on SFTP and SSH, still with no answer. I assume this is something simple, just can't pin-point it... Advice needed.

2
Contributors
1
Reply
2
Views
8 Years
Discussion Span
Last Post by sillyboy
0

perhaps it is the configuration of ftp host to not allow write access. if, as you say you have put +rwx for all users this is the only thing I think would cause this.

when you say you allowed everything on the folder, I assume you put it onto the files inside the folder too?

if it still doesn't work, paste the error you get.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.