0

Hello,

We have a problem. We have a router which has, amongst others, ports 80 and 443 open. Both are pointing to one machine running apache2.

However, https on 443 works, but http on 80 doesn't.

nmap shows port 80 as filtered (why?), and port 443 as open.

I have stopped the firewall on the web server. I have made no changes to the apache2 config since installing it. Still no "It works" page!

Any help gratefully received!

Kind regards

2
Contributors
3
Replies
4
Views
8 Years
Discussion Span
Last Post by sknake
0

If you have port forwarded both ports and one works fine it sounds like a problem on the webserver. Can you connect to the webserver internally using https?

Post your apache config file here as well as the output from iptables-save(run that command as root).

Please use code tags when you post the information

Edited by happygeek: fixed formatting

0

Hello,

thanks for your quick contact. I have read some of your posts - you are well versed in these matters I see!

The https:// was reachable on the LAN.

I have not posted the results - it works now. Why? I have no idea, but we use Magic Online here in France, and I have been battling with this problem with them for over a week. I thought the router was the problem, but that would be unusual, wouldn't it? Yesterday, they apparently brought in an expert, and the upshot is that this morning, after rebooting the router, I have the "It works!" page from apache2 from the Internet and the LAN.

I did suggest to them that it might be a setting between them and the router - we have given notice to the middle of next year, and I would not be surprised if there was a mistaken tweak somewhere...

I have sent an email to them to ask what they have done to the router settings. I don't have an an answer as yet, but I will let you know when I do.

Anyway, thank you for your time!

Kind regards

0

I'm glad you got it working but you're doing the right thing in finding out why it didn't work to begin with as it could likely break again in the future.

Please mark this thread as solved since you have it working now and if the connection issue comes back please update this thread and we can look it in to it. Good luck!

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.