0

I installed apache in my linux fedora 9 server. I went to the /etc/httpd/httpd.conf and i see DocumentRoot "/var/www/html"

so .. i put my index.htm file inside /var/www/html file....... and check the browser to see if i can see the webpage.... unfortunately, it is not working.

I registered a domain name through dyndns.com
I point to domain name to my server's IP
Router is configured to dhcp the same ip to my server
Apache port 80 has already been forwarded

What else should i look at to trouble shoot this? did i miss a step or something?

4
Contributors
5
Replies
6
Views
9 Years
Discussion Span
Last Post by slacke
0

Find the line beginging with DirectoryIndex, it should have a list of all the acceptable index files (index.html, home.html, index.shtml, index.php, ect,...). Depending on the installation package and settings it can have a dozen options, or just index.html. Make sure index.htm is on that list and manually add it if it's not.

0

Find the line beginging with DirectoryIndex, it should have a list of all the acceptable index files (index.html, home.html, index.shtml, index.php, ect,...). Depending on the installation package and settings it can have a dozen options, or just index.html. Make sure index.htm is on that list and manually add it if it's not.

DirectoryIndex index.html index.html.var

for directoryIndex, if i simple added index.php and i have php installed, will it just work ? or I have to configure php ? i changed my index.htm to index.html and it is will not appearing on the broswer.... : (


Do i need to change :
# ServerName example.com:80 to my dns name? thanks

0

How much configuration you would need to do in PHP really depends on the server installation and I couldn't really advice you on that without knowing what's turned on by default (by the time you know what's turned on by default you should know whether you need to configure it anyway) so just give it a try and if it doesn't work look around at the installed (and started) components.

If I remember correctly (I'm 99% sure) the # at the beginning makes it a comment and not relevant to the settings. Apache config files have examples of settings behind #s so you know the syntax. If you just copied the wrong line and the servername field is active you should be able to change it to your domain name, and I'm pretty sure that's something you SHOULD do even if it's not necessary to function.

What happens when you go to your site? Does it load a different page or generate an error (and if so which one)?

If you enter http://Domain/index.html does it load?

Are you trying to load this page through your domain name? If you are try using either your IP (local or public) or http://localhost to see if the issue is with the server or your network configuration.

0

Which IP address did you use.
Remember you should probably take into account NAT.
Also did you see the website when you did http://locahost
(presuming you have apache listening to localhost requests).

0

What about log files.
I don't exactly know where fedora stores them, but it should be somewhere in /var/log.
I have /var/log/httpd and error_log where I see if there is some error in my apache configuration.

I have access_logs too, these contains access informations for each VirtualHost on my apache server.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.