0

hi.

i have 500gb HDD, first i install window 7(64-bit) then after fedora14 on separate partition using Fedora-14-i686-Live-Desktop cd.

so when my laptop is booting it shows a boot screen with two option, fedora OS(as default) and win7 as other.After 3 second, Fedora is automatically starting. I just want to make window7 as my automatic booting OS.

so how to make win7 as my default or primary OS at boot time by which i can load it automatically ?.

any help would be appreciated.

regards
mundvawala

Edited by mundvawala: n/a

3
Contributors
4
Replies
7
Views
6 Years
Discussion Span
Last Post by mundvawala
0

Some systems will give an option of pressing F12 (i think it is) to show the boot menu. Otherwise try F8, if that fails grab a Free Boot manager app, burn to CD or USB and choose the Windows 7.

0

thnx for reply

bt it shows boot option ...bt in that boot option my first OS is fedora which is booting after 3 second by default .so my question is that how could i make window7 as my first OS.. by which i can boot it automatically.

regards
mundvawala

0

http://fedoraforum.org/forum/showthread.php?t=245738
This might help

I don't know if ubuntu is any different with GRUB, but I have ubuntu and this is what I did:
Get the startup Manager Application
Assuming this is the GRUB bootloader
Boot ubuntu, and type: "sudo gedit /boot/grub/grub.cfg" into the console(no quotes)
(enter password)

You should get something that looks like this in the text editor:

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
if [ -s $prefix/grubenv ]; then
  set have_grubenv=true
  load_env
fi
set default="1"

If the text file is blank, try "sudo gedit /boot/grub/menu.lst"

This last line, set default="1" is the thing that you need to change.
The count starts at 0 so to boot the very first option in the menu, put 0, for the second option put 1, third option put 2, etc...

Then save+close. Reboot and it should change the default. (Be sure not to change anything else or it could cause boot problems)

Edited by makman99: n/a

-1

thnk u.makman99..thnk u very much for yr help.

for fedora 14, "sudo gedit /boot/grub/menu.lst" ..i jst executed this command and chaged the default value of it as per my requirements...and it works !!...

thnnx once again ...

Votes + Comments
thank u dude.......
This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.