0

I have sound in my laptop speakers, but when I connect the headphones, the sound still come out from the speakers. I have tried a MILLION different things. Anything works.
I modified the alsa-conf file, but I still have the same problem
does anyone knows how to solve this problem??

My laptop is Asus UL20FT
ubuntu 10.10
sound card: Realtek ALC269VB

Edited by montjoile: n/a

3
Contributors
3
Replies
4
Views
6 Years
Discussion Span
Last Post by montjoile
0

I had exactly the same problem on my old RM Tablet PC.
I found a solution by sheer luck while I was messing about one day. I opened up the sound mixer application (Can't remember the name offhand, but it's the one with all of the volume sliders... Is it ALSA Mixer??) Anyway, whatever it's called, I opened it up and had a look at it's options/settings. Somewhere in the options was a list of all of the sliders which you could choose to show or hide in the application. Turns out there were separate sliders for the headphones and the internal speakers.

As I only tend to use the headphones and not the internal speakers, I muted the channel for the internal speakers and then hid the slider. I set the headphone slider to max and hid that slider too. And to control the volume I just used the main master volume control.

I couldn't find any way of setting it up so the internal speaker would only be used when the headphones were unplugged, but I rarely used it without headphones anyway, so setting the individual sliders was an acceptable solution for me!

BTW: That was a few versions of Ubuntu ago though, so things might have changed since then.
Also since upgrading the tablet to 10.10 I noticed that everything (including the speaker/headphone thing) works out of the box in 10.10.

Edited by JasonHippy: n/a

0

Yes its Alsamixer. Type $alsamixer . Set the levels. And store the settings

$alsactl store

(You will have to run second command as superuser, hence put sudo before)

Select you card by pressing F6 and to get all capture/input slider press F4. Set the level accordingly.

0

One of the first thing I tried is to set the audio levels in alsamixer. Didn't work

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.