I try to entering Manual IP Address from /etc/network/interfaces
like this;

auto eth0

iface eth0 inet static

address 192.168.1.2

netmask 255.255.255.0

gateway 192.168.1.1

but i still can't connected with my internet

but if i try to write /etc/network/interfaces like this

auto eth0

iface eth0 inet dhcp

I can connected with my internet

please help me

I suggest that you go ahead and let it get an address from the dhcp server on your system and confirm the subnet your router/dhcp server is using with ifconfig. What you are probably running into is that the dhcp server gives addresses based on the first number in the range which is probably 192.168.1.2. You could try putting the address out beyond what you think the system is using such as 192.168.1.55.

thank's all (Deep Modi, rch1231) because your suggest, now i can connected clinet and server without dhcpserver. just edit file /etc/resolv.conf

nameserver 192.168.1.1

try this

First three line -same as you entered

add DNS server ip

preferred DNS 192.168.1.11(last one is from your ISP)
Alternative DNS 192.168.1.1

We are glad to hear that your thread has been solved.
Now just Mark it as solved.