0

I am trying to create databases in Ubuntu 14.04 running LibreOffice 4.4.3 and can not due to not connecting with JRE or JDK.

Research carried out and things I have tried lead me to understand I need JDK-8 now instead of JRE. Is this accurate?

JDK-8 and Java 8 are installed. From the command prompt:

$ sudo update-alternatives --config java

  Selection    Path                                           Priority   Status
------------------------------------------------------------
  0            /usr/lib/jvm/java-8-oracle/jre/bin/java         1081      auto mode
  1            /usr/lib/jvm/java-6-openjdk-i386/jre/bin/java   1061      manual mode
  2            /usr/lib/jvm/java-7-openjdk-i386/jre/bin/java   1071      manual mode
* 3            /usr/lib/jvm/java-8-openjdk-i386/jre/bin/java   1069      manual mode
  4            /usr/lib/jvm/java-8-oracle/jre/bin/java         1081      manual mode

$ sudo update-alternatives --config javac

  Selection    Path                                        Priority   Status
------------------------------------------------------------
  0            /usr/lib/jvm/java-8-oracle/bin/javac         1081      auto mode
  1            /usr/lib/jvm/java-6-openjdk-i386/bin/javac   1061      manual mode
  2            /usr/lib/jvm/java-7-openjdk-i386/bin/javac   1071      manual mode
* 3            /usr/lib/jvm/java-8-openjdk-i386/bin/javac   1069      manual mode
  4            /usr/lib/jvm/java-8-oracle/bin/javac         1081      manual mode

From LibreOffice Menu Tools -> Options -> Advanced the following is chosen

Oracle Corporation 1.8.0_111 with path /usr/lib/jvm/java-8-openjdk-i386/jre

Parameters and Class Path sub-dialog boxes are empty also

Since I have several entries for java, I have tried each of them as an alternative and the corresponding entry under Tools -> Options -> Advanced

Thanks for taking the time to read this. Can anyone offer insight how to solve this?

3
Contributors
6
Replies
25
Views
4 Months
Discussion Span
Last Post by rproffitt
0

Isn't version 5 of LibreOffice out?
Also, doesn't it take more than JDK? Some SQL? MySQL?

Just pulling from memory here, did not google this.

1

I have libreoffice 5.1.6.2 on my Mint system. Works fine with the default Java runtime. No JRE required.

Votes + Comments
Bring out your dead (versions.)
0

Doesn't matter if it is LO 4 or 5. Java of some form is required.

At the least, Java is required to use the internal database engine of LO. I am not trying to connect through a JDBC or ODBC to a MySQL database. I would need to resolve this anyway if I was connecting to an external database.

Still looking and hoping for help.

0

I never said I was not in favour of upgrading to LibreOffice 5. This is not an issue whether upgrading to the most recent version has bearing. LibreOffice 5 like LibreOffice 4 still requires JRE or JDK to work which I stated from the outset is the challenge.

Side bar: There is indication LO developers will eliminate Java dependencies by moving to Python, but we have not reached that milestone yet.

I upgraded to LibreOffice 5 and am still getting the same message after going through the database wizard:

The connection to the data source "tst4" could 
not be established

SQL Status: HY000

The connection to the external data source could
not be established. No SDBC driver was found 
for the URL 'sdbc:embedded:hsqldb'.

You do the google research on that error and it comes back that Java is not working with LibreOffice 4 or 5.

I have tried both LibreOffice 4 or 5 with the various flavours of Java JDK or JRE installed on my system and nothing prevails as a solution.

@rproffitt: I looked at the video you suggested. Attached is a screen shot of when I start the database wizard LOBase.png

0

I'd hit the LO forums but it looks like that error has priors. Such as it may require the 32 bit version of Java. Just get the JDK as it will have the runtime and dev kit all in one.

Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.