0

hi!! i'm new to java and need some help! i installed j2sdk on fedora4.it installed successfully.i could also compile & run 2 programs successfully. but after i restarted the computer and tried compiling using javac it gave me an error...
javac:symbol lookup error:/usr/lib/libjc.so.6:undefined symbol : ztvn4java3awtgeo118

i tried it so many times and also reinstalled it,but it gives me the same message.somebody please tell me what is the problem

4
Contributors
6
Replies
7
Views
11 Years
Discussion Span
Last Post by laddu
0

You're in the wrong forum. Try posting in the Tech Talk/Unix and Linux forum for problems with Linux. This forum is about problems related to developing software with Java.

0

well, you're not using the official JDK there.
Check your $PATH and $JAVA_HOME environment settings and make sure they point to your JDK installation.
As it is you're pointing to gcj which is to put it bluntly a disaster, I'm surprised you got anything to compile and/or run under it at all.

0

how to set the $PATH..i have no idea,plz help!

To view what's currently in your PATH or JAVA_HOME variable:

# echo $PATH
# echo $JAVA_HOME

You'll see a list of paths seperated by colons. If the path where you installed Java is not in either of these, you should probably add them like so (add them to both, just to be safe):

# PATH=$PATH:/path/to/add
# JAVA_HOME=/where/java/is/installed

Of course, these paths are only temporary. To permenantly add them, you'll need to edit your .bash_profile or some other startup script that your distro uses. Again, refer to documentation for exact instructions.

0

i'm sorry for posting in the wrong forum

And thanx to all your help,my java is running now.I had to set $PATH & $JAVAHOME /etc/profile.Thanx a lot

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.