0

I am mostly following this post to install OBOE in MAC OS 10.9:
https://projects.coin-or.org/OBOE/wiki/MacosxOboe

However, in step 4:

I tried to install LAPACK++ with failure from this source:

I type ./configure

configure: error: Blas/Lapack was not found.
*** This means Lapack++ and matrix support cannot be compiled.
*** This makes this library unusable. Please get blas and lapack
*** installed. If you do have these installed, use the options
*** --with-blas=<libname> or --with-lapack=<libname> and/or set
*** the env variable LDFLAGS to include the appropriate linker
*** flags.

But I have libblas.a, liblapack.a, librefblas.a, libtmglib.a in my /usr/local/lin folder. Can any one help?

Edited by pritaeas: Moved.

2
Contributors
1
Reply
9
Views
2 Years
Discussion Span
Last Post by rubberman
0

Have you verified that both the basic lapack and blas packages have been properly installed? Look in /usr/lib for the appropriate libraries, or download and install them directly.

In any case, lapack and lapack++ are system performance testing tools, primarily to scope the math processing capabilities of a system. Is that what you are trying to do?

Also, libraries in /usr/local/lib will not be seen by default. There are other ./configure options that will find them there. In addition, you may need to set the configuration to use static libraries instead of the default shared libraries (such as libblas.so, etc). Execute the command ./configure --help for a full lising of the options.

Edited by rubberman

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.