0

I have an ADSL Internet connection. the modem is connected to a Wireless Router which is connected to the Ethernet Port.

btw. the routing function is done by the ADSL modem and not the wireless router.

now, my laptop is connected to the wireless network created by the wifi router. till about a month ago. everything worked fine. I came back after a month and the internet as accessed via wifi has become pathetically slow despite strong signal strength. more specifically. the problem is as follows.

every request from my laptop seems to get the net only for a limited period of time (about 1-2 seconds). eg. if i download a file, given my current speed of 1Mbps(small b), about 0.1-0.3 Mb gets downloaded and then it just stops. if i retry the download, another 0.3 Mb and then it just stops.
ive even noticed it with web pages(naturally). i sometimes have to refresh the page twice or thrice for it to get completely downloaded.

Note: this is only for internet accessed via wifi. the net still seems to work fine on my desktop.

So, is there anyway to ascertain/rectify the cause of this. i.e. wether it is a problem with the router or with my laptop.

note. modem is connected to router via ethernet cable
router is connected to ethernet port of desktop via etherne cable
router model: Belkin Wireless G Router.

4
Contributors
6
Replies
13
Views
5 Years
Discussion Span
Last Post by FelineHazard
0

Have you looked into the wireless adapter in the laptop certain models react badly with some routers it might be a firmare update.

Have you reset the router completely and started from scratch??

0

when you mean reset, do you mean restart or reset as in press the reset button and reconfigure the router from scratch?

Also, regarding the adapter, i mentioned that things worked fine up until a month ago. im sure i have not updated any hardware adapters.

when you say 'looked into' what exactly do you expect me to have done?
thanks 4 reply.

0

What sgunnery is suggesting is that you reset the wireless router back to it default settings.

Another thing you can try just to ensure that this problem is strictly related to the wireless connection is to connect the laptop via the wired ethernet connection and test to see if there is any slowness.

What you may want to try is to go in to device manager (on the laptop), uninstall the wireless NIC, rescan, and provide Windows with the most updated drivers. Sometimes, when devices start acting flaky, unistalling them and reinstalling fixes the issue.

Finally, make sure that your wireless router's firmware is up to date as well. Go to the vendor's support site and verify that you have the latest firmware, if not, update your router's firmware as well.

0

Sorry I didn't explain my post in more detail it was a little rushed

I mean to find out the exact make and model on the wireless adapater in your laptop I have some issues with my wife's laptop when changing to a Virgin Media Superhub the Atheros adapter didn't like the router..do a little research into what's in your laptop.

And what JorgeM is saying is very helpful try everything there devices can be flaky and tempermental and just not what to work a quick uninstall/re-install usually works.

Keep me posted

Regards

0

Note that the problem might be on the laptop side, and not on the router-side.
Try and clear everything your laptop knows about your wireless connection. Pass, credentials, everything. Might be, that something's corrupt, so clearing it and reconnecting could solve the issue.
Good luck,
-FH

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.