Hello,

I'm trying to mount an ISO file. I tried a couple of applications to do this (four of them) but nothing works. I'm using Windows 10. I know that Windows 10 comes with the functionality of mounting, but that doesn't work either. What can be the problem?

Help me,

thanks

Re: Mounting ISO files 80 80

Tell more. Why I ask is I had a few folk trying to mount an ISO of a Linux install or boot image and they were flummoxed over how to make that work.

If you just need to get what's at or inside the ISO I've been using 7-Zip from ninite.com.

Re: Mounting ISO files 80 80

Virtual CLone Drive also works. And it's free.

Re: Mounting ISO files 80 80

Another good, free option is ImDisk (https://sourceforge.net/projects/imdisk-toolkit/). It lets you mount CD, HDD, and FDD images.

commented: ImDisk doesn't work either. Thanks though +0
Re: Mounting ISO files 80 80

@Xozz. In your other post the odds change as it appears you may have some bum ISO files. You can bet I've run into folk that had bad files and would blame all the apps for them not mounting or opening.

Re: Mounting ISO files 80 80

MagicISO works on my Windows 10 Home laptop.

Re: Mounting ISO files 80 80

I tried a couple of programs in Windows 10 and Windows 7 and the result is always the same: "Cannot do this"

commented: This means to me these ISO files may be bum. +15
Re: Mounting ISO files 80 80

In the passed they worked.

Re: Mounting ISO files 80 80

All it takes is a little corruption and blammo. This is why you need someone else to test them out.

Also, that was then and now we are in now now. See https://www.youtube.com/watch?v=nRGCZh5A8T4

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.19 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.