0

Hi,

Hello all. I installed SQL Server 2005 on Windows 7 together with SP3. I set the surface area configuration to allow TCP/IP and named pipes. When i try to connect the machines running SQL, i fail, i cant access it. Neither can i change any settings in the surface area configuration. I get the following error

***
A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) (Microsoft SQL Server, Error: 2)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=2&LinkId=20476
***

Any ideas as to how i can work around this challenge?

4
Contributors
5
Replies
8
Views
7 Years
Discussion Span
Last Post by mikedsa
0

Let me try to understand you. You try to connect other machines to a Windows 7 computer that has SQL Server 2005? Are they all the same version of SQL Server? Have you checked your firewall / DNS settings?

0

Samaru,

Yes both machines are running on win 7. They both run SQL server 2005. No firewall settings are in place and i had no looked at the DNS settings.

If i am to change the port settings for SQL server would that help? I am thinking maybe if i manually configure the ports i might succeed.

0

Are you using SQL Server 2005 Express Edition or developer Edition?

You can try the following-

There are 3 steps to it-

· Enable remote connections on the instance of SQL Server that you want to connect to from a remote computer.
· Turn on the SQL Server Browser service.
· Configure the firewall to allow network traffic that is related to SQL Server and to the SQL Server Browser service.


You have probably completed step 1.

Step-2
On the SQL Server 2005 Surface Area Configuration page, click Surface Area Configuration for Services and Connections.

On the Surface Area Configuration for Services and Connections page, click SQL Server Browser, click Automatic for Startup type, and then click Apply. Note When you click the Automatic option, the SQL Server Browser service starts automatically every time that you start Microsoft Windows.

Click Start, and then click OK.


Step-3

1. In Windows Firewall, click the Exceptions tab, and then click Add Program.
2. In the Add a Program window, click Browse.
3. Click the C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Binn\sqlservr.exe executable program, click Open, and then click OK


Hope this works. Let me know.

0

Oops Forgot something

Do the same for Sql Server Browser Service-

1. In Windows Firewall, click the Exceptions tab, and then click Add Program.
2. In the Add a Program window, click Browse.
3. Click the C:\Program Files\Microsoft SQL Server\90\Shared\sqlbrowser.exe executable program, click Open, and then click OK.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.