0

High CPU Usage despite nothing showing on Task Manager or Process Explorer.

Greetings all, I hope this is the correct area to post this to, If not I apologise and could it be redirected to the correct area. Anyway, I do hope someone can help with this infuriating problem, and many thanks in advance.

I was asked to have a look at a relatively new Acer Aspire 6530g laptop recently that was beginning to become almost unusably slow all of a sudden. The system (which comes with 4gb of ram) literally can no longer run a couple of simple applications at the same time. Displaying typical behaviour of high CPU usage, ie taking a long time to respond, typed sentences seeming to pause and then jump to the end, video noticably jerky accompanied by a crackling through the speakers.

The system had a fresh re-installation of Vista done, which seemed to solve the problem briefly, reappearing again after a week or so, and then upgraded from Vista to Windows 7 in an attempt to solve the problem, again the symptoms appeared to stop after the upgrade (or weren't as evident) and returned yet again after only another week or so.

First thing i did was check task manager for something slowing the system. I suspected perhaps some malware or a trojan on the system.

This is where it gets weird. Nothing. If for instance theres just 1 browser window playing a flash game, it slows to a crawl. CPU shows 75-95% usage, yet nothing is seemingly using it. To go a little deeper I installed sysinternals process explorer to see a little deeper into what might be causing it. Again, nothing. Showing overall High CPU usage, but nothing appeared to be using all of the CPU.
Whilst something relatively intensive (playing video for instance) was happening, this process could clearly be seen using a percentage of the CPU, but nothing else seemed to being using the rest, however the CPU still showed overall usage of 90-100%.

After extensive tests on the system it came up clean every time for malware or spyware or anything of that nature hidden on the computer. I am absolutely certain the system is trojan/malware free. I tried replacing drivers with newer versions from the manufacturers website as well to seemingly no avail.

Frustrated by this I hit the internet to search for a solution. I found a number of different posts on forums by, surprise surprise, frustrated acer aspire users describing these same symptoms. But with no definate solutions offered.

The closest I've come to something that would make sense was 2 articles. Firstly this blogpost...

http://frazzleddad.blogspot.com/2006/03/lousy-performance-high-hardware.html

Which describes the ATA/IDE controllers reverting back to PIO mode instead of Ultra DMA. Which wouldnt show up on task manager but would eat up CPU. However, the description given in that article describes checking for it on windows XP. This system is now Windows 7. I've checked all the Controllers in Device manager on this system, (theres more than just Primary and secondary IDE Channels, kinda confusing) But some either show the transfer mode as Ultra DMA or don't display anything. To try the solution offered in that blogpost I uninstalled all the controllers and let windows redetect and reinstall all of them automatically, however it didnt seem to make any difference.

Secondly, i found this question on Experts-Exchange, which sounds like my prob, is unsurprisingly yet again an Acer Aspire, but which i cannot view the answer for because experts-exchange is now commercial. : \

http://www.experts-exchange.com/Hardware/Laptops_Notebooks/Q_21558521.html

Oh, and to rule out hardware problems, I booted the system in Ubuntu Linux from CD and visited the same Flash sites that definately caused slowdowns in windows. Everything ran very quickly, no slowdown. In fact, Flash seemed to run far too fast. So whatever it is, its in windows. But What?

If anyone can offer any assistance with this I would be most grateful, as well I suspect, will be the many acer aspire users who might find the solution here. Thanks. :)

5
Contributors
12
Replies
13
Views
7 Years
Discussion Span
Last Post by Dyls
0


Oh, and to rule out hardware problems, I booted the system in Ubuntu Linux from CD and visited the same Flash sites that definately caused slowdowns in windows. Everything ran very quickly, no slowdown. In fact, Flash seemed to run far too fast. So whatever it is, its in windows. But What?

/QUOTE]
that eliminates all hardware except the harddrive ,may be getting bad

0

Thanks for your reply, I'm pretty sure the harddrive isn't damaged in any way, its still pretty new. I suspect it may be something using interrupts, but not sure what or how to track it down. Has anyone else had this problem, or better yet had it and solved it?

Edited by Verus: n/a

0

Then may be some other hardware or software issue, you need to scan it online in order to find the issue.

0

Hi,
I know you have stressed that you have checked for malware and everything is clean but everything you say about the problem points to malware. I am not saying that you do have a virus but this type of problem is very often the fault of a virus. The best virus detector program will not get every virus every time.
I suggest that if you have not tried these three things, you give them a go.
1. Download and run Trend Housecall in safe mode:-
http://housecall.trendmicro.com/
2. Download, update, reboot and run Malwarebytes:-
http://www.malwarebytes.org/
3. Download and run Ccleaner:-
http://www.ccleaner.com/download

0

Many thanks for the replies. CCleaner is already installed on the system, I'll give Trend housecall and malwarebytes a go as well tho thanks. Its such a strange problem to see happening because its so obvious something is badly slowing the system, yet nothing appears to be showing up.

0

check task manager again going into resource monitor ,see attached image

using snipping tool in start ,capture your screen shot of yours and post it maybe

Edited by caperjack: n/a

Attachments Capture.jpg 296.89 KB
0

Thanks for all the help and software suggestions on this thread guys. A complete fresh install of (non acer branded) 7 seems to have (so far) solved the issue. Which would seem to suggest that some of acer's own bundled software was slowing the system somehow. I had to convert the digital download of 7 used for the Vista upgrade into a bootable disk in order to use it tho. If anyone else is attempting to try that, a good guide is here:

http://www.sevenforums.com/tutorials/30470-make-bootable-iso-student-d-l.html

Thanks again!

0

Hi,
Good to read that you seem to be running well. I would have to disagree about the Acer comment as it would mean that all Acer machines sold running 7 would have that problem. I would have to say that something in your installation was at fault When you load that much data in one go it would be easy for a small glitch somewhere.
Anyway, please mark this thread as solved if you are now happy. Even if it was you in the end that fixed the problem.

0

I would tend to agree, but I simply couldn't track down any other explanation. The original re-installation was done using Acer's own Factory restore disks and apart from Microsoft office, there wasn't any other software installed on the system when it started slowing down. Odd. Anyway, a moot point now! (For the time being anyway) :)

0

Dunno if this issue possibly could have been solved by going into Acer Empowering Technology and the ePower Management and then switching from Balanced or Power Saver to High Performance. I was having the same issues and resolved it that way .

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.