Hi there,
I'm using asp.net (c#) framework version 1.1 and trying to connect to my Oracle database 10G ( which installed on the same server as the IIS and I'm getting the following error:
OleDbException (0x80004005): error while trying to retrieve text for error ora 01019

I can connect through sqlplus and I did give aspnet user full control on my Oracle_Home.
In addition I defined the ORACLE_HOME in the system environment and in the system PATH.
although I had few oracel version installed I removed them all (from the registery as well) and now I only got this 10G as my only Oracle_Home.

this is the code I'm using for openning the db connection:
using System;
using System.Collections;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Web;
using System.Web.SessionState;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.HtmlControls;
using System.Data.OleDb;

string constr = "Provider=MSDAORA.1;Data Source=wstdb;User Id=stdb;PASSWORD=stdb;OLE DB Services=-2";
OleDbConnection conn = new OleDbConnection(constr);

I got the error while opening the connection.

I realy need help.


13 Years
Discussion Span
Last Post by Kate Albany

I am not sure what your problem is being caused by, but this is the definition of ORA-01019 if you didn't know.

ORA-01019: unable to allocate memory in the user side
Cause: The user side memory allocator returned an error.
Action:. Increase the size of the process heap or switch to the old set of calls.


I figured it out and here is what I did:
I've notice that I still have leftover of Oracle9i footprints in some of the registry key such as InprocServer32 so I change the value to the existing OracleHome -10 to E:\oracle\product\101~1.0\Db_1\bin\oradc.ocx
After a reboot it partially worked and gave me another error : tns could not find service name although it's properly configured.
Then I took the same code to a new project and it worked!!!

It's very strange but we are dealing with computers....


This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.