Hi there,
I'm using asp.net (c#) framework version 1.1 and trying to

connect to my Oracle database 10G (10.1.0.2.0) which installed

on the same server as the IIS and I'm getting the following

error:
OleDbException (0x80004005): error while trying to retrieve text for error ora 01019

I can connect through sqlplus and I did give aspnet user full

control on my Oracle_Home.
In addition I defined the ORACLE_HOME in the system

environment and in the system PATH.
although I had few oracel version installed I removed them all

(from the registery as well) and now I only got this 10G as my

only Oracle_Home.

this is the code I'm using for openning the db connection:
using System;
using System.Collections;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Web;
using System.Web.SessionState;
using System.Web.UI;
using System.Web.UI.WebControls;
using System.Web.UI.HtmlControls;
using System.Data.OleDb;


string constr = "Provider=MSDAORA.1;Data Source=wstdb;User

Id=stdb;PASSWORD=stdb;OLE DB Services=-2";
OleDbConnection conn = new OleDbConnection(constr);
conn.Open();

I got the error while opening the connection.

I realy need help.

Thanks,
Adi

Recheck your Connection String :

pseudo_code:

oConn.Open "Provider=msdaora;" & _
           "Data Source=MyOracleDB;" & _ 
           "User Id=myUsername;" & _
           "Password=myPassword"

Check my website (in sig below) for a link to the Microsoft Oracle Provider and you can download it from here

For example You have msdaora.1 as your provider in the connection string.

Hope this helps

Thanks Paladine.
I did install the oracle provider as u suggest and try to change the mdsaora.1 to mdsaora but still same problem...

any other suggestion?

Thnaks again. :)

Hmmm

I love a challenge. **note: Please provide the error message you get **

OK I am at work right now on a break, so i will have to check it out tonight when I get home.

I will Post back then!

EDIT: Some information came to light --->


I would assume with the changes made your code would look similar to this:
(Note case as well, C# is case sensitive, not like VB.NET)

// Setup connection string to access Oracle9 database
        // using the TNSNAMES connect string ARK2
        string connectionString = "Provider=MSDAORA;" +
        "Data Source=ARK2;User ID=scott; Password=tiger";

        // Instantiate the connection, passing the
        // connection string into the constructor
        OleDbConnection con = new OleDbConnection(connectionString);

        // Open the connection
        con.Open();

        // Create and execute the query
        OleDbCommand cmd = new OleDbCommand("SELECT ename,job FROM emp",con);
        OleDbDataReader reader = cmd.ExecuteReader();

        // Iterate through the DataReader and display row
        while(reader.Read()) {
            Console.WriteLine("{0} - {1}",
            reader.GetString(0), reader.GetString(1));

Or did your code follow the managed provider from Microsoft ?

i.e.

using System.Data.OracleClient;
OracleConnection conn = new OracleConnection("Data Source=oracledb;
    User Id=UserID;Password=Password;");

You could try using a DSN rather than this method that you are getting the error on(DSN-less)

i.e.

ConnStr = "Provider=MSDAORA;DSN=oracle;";

But again I will look more into it when I get home! :cheesy:

Thanks Paladine.
I did install the oracle provider as u suggest and try to change the mdsaora.1 to mdsaora but still same problem...

any other suggestion?

Thnaks again. :)

Hi,
I figured it out and here is what I did:
I've notice that I still have leftover of Oracle9i footprints in some of the registry key such as InprocServer32 so I change the value to the existing OracleHome -10 to E:\oracle\product\101~1.0\Db_1\bin\oradc.ocx
After a reboot it partially worked and gave me another error : tns could not find service name although it's properly configured.
Then I took the same code to a new project and it worked!!!

It's very strange but we are dealing with computers....

Paladine, Thanks a lot.
I realy appreciate it :-)

Cheers,
Adi

GREAT!

My pleasure!

Well that works, not if I can only get mine to work over the network. Arrrggh! Hehe, oh well.

This article has been dead for over six months. Start a new discussion instead.