Hi
I Have an App that connects to an 2010 access DB (.accdb) using OELDB Driver.
In my dev pc the application works fine.
I also tried installing it on different pc and it worked fine using a access database runtime.
Now when Installing it on a pc running access 365 I get ''Unrecognized Database format error'' even after installing the same access database runtime I still.
What could be causing this error?

I'd get to the Microsoft forums on this one. Or just call it in.

https://support.microsoft.com/en-us/help/946205/error-message-when-you-try-to-open-a-compiled-database-file-or-a-compiled-project-file-in-access-2007-this-database-is-in-an-unrecognized-format is errily similar and what I'm finding are machines that are not current with service packs or updates.

-> Side note: This is partially why a new ransomware is spreading so quickly.

Yes I Contacted Microsoft and yes there was a SP2 for the runtime.

Thanks

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.18 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.