Hello everyone.
I just started incorporating directx into my programming and I am still unfamiliar with this territory. I installed directx version 9 into my computer after I had removed all previous versions. From my project settings I linked all the necessary file such as: d3d9.lib, d3dx9.lib and winmm.lib. From the tools option I added the path to where all includes and library file are located. Compling and linking showed no errors but when I go into debug mode I get lines of errors from the debug log. It logged: "Loaded 'ntdll.dll' no matching symbolic information found" and it doesn't stop there. It precede to the others too and said the same thing: "\system32\kernel32.dll" - d3d9.dll,d3d8thk.dll,gdi32.dll,user32.dll no matching symbolic information found." I couldn't find the cause of this problem.
I've tried uninstalling all directx version and I even uninstall Visual Studio C++ 6.0, which I used often with no problems. The result was still the same.
I have been struggling with this problem for months now. I couldn't find any sites, forums, or documentation involving my situation. If anyone can point out what I am doing wrong please give me some pointers. I tried my best to make asking someone else a last resort and so I am really desperate for help. Many thanks for your assistance. Sadaka

>>no matching symbolic information found." I couldn't find the cause of this problem.
You are uisng the release version of those DLLs which do no contain debug information. That's just a warning saying you can not step into any of the functions that's in those DLLs. Otherwise you should be able to debug your own program normally as long as you compiled it for debug instead of release.

In response to jbenet: Yes sir, I installed the SDK for DirectX 9.0b. I tested the utilities that came with the kit and they seem to be functioning without a fuss. However, my projects was unable initialize DirectX or any of its devices. I am using windows XP operating system. Could this be the issue, sir?
In response to AncientDragon: Yes sir, I do agree. I have noticed that I was not able to step into the next line of code. It would always give me the message saying, "Application.obj and Application.exe does not exist; would you like to build it?"
I am terribly sorry, sirs, for not being able to provide you with anymore detailed information. I must admit my head is spun around. I really appreciate both your help. I will try a complete wipe out of the hard drive and installing both directx and visual studios again. If the problem persist then I will just have to make do without DirectX or just downgrade to earlier versions. Thank you both again. Sadaka

This article has been dead for over six months. Start a new discussion instead.