When trying to run my application it says it needs "libglib-2.0-0.dll" to run. The file is in\glib-2.14.6\bin but I don't seem to be able to link to it.
I am using Eclipse so I have tryed setting MinGW C++ Linker -> Libraries->Library search path (-L) to "C:\glib-2.14.6\bin" and Libraries (-l) to libglib-2.0-0.dll. However it is still not found.

Does anyone know what I sould do or where to find more info on this?

thanks!

This is a run-time problem rather than link-time problem (i.e. linker search path properties are of no help).
Modify your computer's PATH environment variable to include the C:\glib-2.14.6\bin directory.
You need to restart Eclipse in order for the change to take effect.

I tried that already, didn't work =(

Any other suggestions?

I solved it. The path worked (the error was somewhere else).
Another question though, I also had to set a path to C:\GIMP-2.0\bin to find the file "intl.dll" when I run the program. Why? I am not using GIMP (I was just lucky to have it installed on my computer..)

One or more of the .dlls your application uses, uses intl.dll.
You might find the dependency walker helpful, it loads an executable (dll, exe etc) and looks up and displays all dependencies, it's free and quite handy at times, see
http://www.dependencywalker.com/