I have a VB.NET application created in Visual Studio 2005. The application uses crystal reports. It works fine on the developer machine, but I am receiving the following error on a client machine:

System.IO.FileNotFoundException: Could not load file or assembly 'CrystalDecisions.Windows.Forms, Version=11.5.3700.0

This is a standalone executable and not distributable application. I tried manually running the crystal reports .net distributable application on the client machine. The file is called "CRRedist2005_x86.msi" and its found under "C:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\BootStrapper\Packages\CrystalReports"

This installed several DLL files on the client machine, which I verified and found under the following directory "C:\Program Files\Common Files\Business Objects\2.7\Bin"

However, it did not install the CrystalDecisions.Windows.Forms.dll that is found on my machine under "C:\Program Files\Common Files\Business Objects\2.7\Managed"

I tried copying these files over to the client machine and registering them manually, but it didnt like that either.

Someone please point me in the right direction! Thanks!

What you'll have to do is add the prerequisite for Crystal Reports under your setup properties, or project properties depending on if you are using a install wizard or not. If you have a installation project, you can go to Project -> Properties and select prerequisites, and make sure that Crystal Reports is checked. If you are using the regular installer, Go to the project properties, select publish, and go to prerequisites, and make sure crystal reports is checked there. Then when you setup the application on the client machine, make sure you install using the setup file instead of the .msi, and it will install the crystal reports .dll's, either download them, or if you have them packaged, itll go to the location you specified under prerequisites.

I had this same issue only with a Click Once deployment. The update process that runs every time the program runs (how I have it set up) would not pull down the prerequisite "Crystal Reports for .NET 2005"and yes that fixes the problem. Quick solution was to uninstall and reinstall and that picked up the install for Crystal Reports and the report would run after that. Not a clean solution but one that works. Just a heads up if your using Click Once.

This article has been dead for over six months. Start a new discussion instead.