Hey Daniweb Python forumers,

I'm guessing that this is a Vista thing, but when I run my wxPython programs in Vista by double-clicking the file, I get errors from the computer saying that "python.exe has stopped working". I also use the IDLE IDE, so when I run the program from IDLE, it works fine the first run, but the second run will cause the program to crash. Thus I must close and re-open my file every time I want to close and test my code, and I don't have the option of double-clicking the file. However, all of my programs run fine on XP. This is why I think it's a Vista thing.

Is there a solution to this? Or this a Vista thing where I just have to deal with it?

Thanks in advanced for the help~

I haven't had too many problems with wxPython programs on Vista, but the OS has screwed me up in many other ways. Whenever I can I use an older XP machine.

Maybe you can relax the super childish default security scheme they use to a lower level?

re-install wxpython and run as admin by right click. sometimes becomes a problem when you install it with less admin rights!

I see, thanks for the advice!

My Python instructor told me that right-clicking the file and opening it in IDLE causes things to screw up with wxPython, so opening IDLE first and then locating the file fixes the IDLE error.

Thanks!

When I try to program with wxPython using IDLE (on Vista), it also gives me this screwed up error about the wx.App() needing to be created first, all the times I run it after the first attempt. I gave up on this after a while and just switched to programming in Notepad++. Or I just boot Linux and use gedit.

This article has been dead for over six months. Start a new discussion instead.