Hi all.
I'm having a difficult time working with visual studio 6.0. I have a project which i'm editing, and i need to add a combobox to a form. The problem is i've added items to the combobox throught it's properties, and yet when i run the program, only the selected item appears. When i click the arrow to list the items, there is nothing there.

Does anyone have any idea why this is happening?

Thanks.

Recommended Answers

Is this an MFC project? Try adding them at runtime in the OnInitDialog() (CDialog) or OnInitInstance() (CForm)

Jump to Post

All 2 Replies

Is this an MFC project? Try adding them at runtime in the OnInitDialog() (CDialog) or OnInitInstance() (CForm)

Yes, it's an MFC project.

At first, i was trying to populate it at runtime from a database, and then by just calling AddString(), inside a frmPopulate function which also populates some other textboxes on the form. It didn't work, but the weird thing is, the original programmer has done the same thing. So i've just immitated him.

What happened now is that i copied his combobox from another form, and pasted it to my form, and it worked. I check the properties and couldn't find anything differing in the settings.

I don't know. I was wondering if there are other options to the control not visible in the properties that i need to set. Could it be that the drop down size is too small?

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.