0

I have compiled a project with "Build Solution" in VC++ 2008 Express Edition wich have worked fine all the time.

Suddenly without doing any changes nowhere after the last F7 (1 minute ago), I do get this Error message:

1>Linking...
1>LINK : fatal error LNK1104: cannot open file 'E:\Documents and Settings\aaa\My Documents\Visual Studio 2008\Projects\Form1\Debug\Form1.exe'

The Form1 is in place in the debugfolder as usual. I dont what this depends on and what I can do to make it work. I have also tried to "Rebuild Solution" without success.

5
Contributors
5
Replies
12
Views
7 Years
Discussion Span
Last Post by green_frog
Featured Replies
  • More than likely that program (Form1.exe) is still running in the background. Do Ctrl+Alt+Del to get tack manager then look at the list of running applications. If Form1.exe is listed there then try to kill it. If not, then you may have to reboot your computer to get it out … Read More

1

More than likely that program (Form1.exe) is still running in the background. Do Ctrl+Alt+Del to get tack manager then look at the list of running applications. If Form1.exe is listed there then try to kill it. If not, then you may have to reboot your computer to get it out of memory. I get that problem too on rare occations because the program will die to to program bugs.

Edited by Ancient Dragon: n/a

0

Check to see if it's still running somewhere (if it's not in the taskbar, open the task manager and see if it's still there, end the process if it is). Failing that try rebooting. If that still doesn't help you might have to create a new project and incorporate the existing source files.

EDIT: LOL AD had me by 2 seconds or less hehe

Edited by jonsca: n/a

0

Yes that was correct, the Form1 was still running in the background.

I thank you very much for that.

0

There is also a possibility that the code resides in a folder which is a sub directory of the MS Visual C++ directory in which case the file will not be linked because the link file can not be seen. Create a completely seperate directory to store the code and compile debug and link in that directory and things will work.

0

I have had that problem before. Its probably because you have run the program before and not closed the application and now your trying to run it again.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.