Note: I program in C++ Not C#.

In visual studio 2010, Where u press release or debug, next to it has a box with win32..
How can I change it to x86.. I tried pressing New and edit and stuff and configuration manager but it doesnt have the x86 choice... only Ithanium, x64, x32.. But if I choose Ithanium, it will not run on any computers that dont have an Ithanium Processor.. If I chose x64, it doesnt run an any computer that doesnt have a 64bit OS.. If I press x32, It doesnt run on a x64 computer :S

It seems as though my program only crashes on non-development machines..

I read that the solution to solve it is the following in which I cannot find x86:

First, select Tools...Options...Projects and Solutions and make sure the Show advanced build configurations option is checked.

Then select Build...Configuration Manager and click the Platform dropdown. If the x86 option is not in the dropdown list then select
<New...> and x86 from the New Project Platform dialog. Select x86 as the Platform option. After compiling your application it will in 64-bit WoW (32-bit Windows) under 64-bit Windows.

Others with the same problem (might be described better than I can):

http://social.microsoft.com/Forums/en-US/Offtopic/thread/642a63cb-a05b-41f3-8070-31f4f6a2113c
and
http://social.msdn.microsoft.com/Forums/en/Vsexpressvb/thread/7fc988c6-6821-469b-8138-1767ebaffaa4

Anyone know how I can get this x86 option??? I really need it bad!

Things Tried: Re-installing (not by uninstalling first and then reinstalling but rather I double clicked the VS2010 setup file, pressed repair/reinstall.. waited 1hr or so, restart.. still not there! :(

Installed vs2008 to see if itll be there, its not! :(

The only info I can get on the crashes is the following:

<?xml version="1.0" encoding="UTF-16"?>
<WERReportMetadata>
 <OSVersionInformation>
  <WindowsNTVersion>6.1</WindowsNTVersion>
  <Build>7600 </Build>
  <Product>(0x3): Windows 7 Home Premium</Product>
  <Edition>HomePremium</Edition>
  <BuildString>7600.16539.amd64fre.win7_gdr.100226-1909</BuildString>
  <Revision>1</Revision>
  <Flavor>Multiprocessor Free</Flavor>
  <Architecture>X64</Architecture>
  <LCID>1033</LCID>
 </OSVersionInformation>
 <ParentProcessInformation>
  <ParentProcessId>3696</ParentProcessId>
  <ParentProcessPath>C:\Windows\explorer.exe</ParentProcessPath>
  <ParentProcessCmdLine>C:\Windows\Explorer.EXE</ParentProcessCmdLine>
 </ParentProcessInformation>
 <ProblemSignatures>
  <EventType>APPCRASH</EventType>
  <Parameter0>MyFirstProgram.exe</Parameter0>
  <Parameter1>0.0.0.0</Parameter1>
  <Parameter2>4c1137bb</Parameter2>
  <Parameter3>KERNELBASE.dll</Parameter3>
  <Parameter4>6.1.7600.16385</Parameter4>
  <Parameter5>4a5bdfe0</Parameter5>
  <Parameter6>e0434f4d</Parameter6>
  <Parameter7>000000000000aa7d</Parameter7>
 </ProblemSignatures>
 <DynamicSignatures>
  <Parameter1>6.1.7600.2.0.0.768.3</Parameter1>
  <Parameter2>1033</Parameter2>
 </DynamicSignatures>
 <SystemInformation>
  <MID>24344505-ED64-4A4F-931A-17CA2201C340</MID>
  <MarkerFile>1025_ACER_AX1700-X64</MarkerFile>
  <SystemManufacturer>Acer</SystemManufacturer>
  <SystemProductName>Aspire X1700</SystemProductName>
  <BIOSVersion>R01-B1</BIOSVersion>
 </SystemInformation>
</WERReportMetadata>

Edited 5 Years Ago by triumphost: n/a

MS-Windows only runs on x86 or Intel based computers. Therefore win32 and x86 are the same thing.

>> If I chose x64, it doesnt run an any computer that doesnt have a 64bit OS.. If I press x32, It doesnt run on a x64 computer

I use 64-bit Windows 7 and run a lot of 32-bit programs. VC++ 2010 Express is 32-bit and generates only 32-bit code. Works without a problem on my computer.

:( Doesnt work for me.. I compiled my program like 47 times already in 32 bit. When transfered to any of my friends' computers, it doesnt run.. It crashes still and gives that error.. *sigh*

Do your friends' computers have the Visual C++ Redistributables? (they come as part of the normal windows updates now, but they may have ignored them or removed them). If you have .dlls that go with your program, you have to make sure the other computer has them too.

This article has been dead for over six months. Start a new discussion instead.