I am running into a strange error everytime I use lxml.etree and was wondering if anyone else has ran into this problem before. It was not until, what I believe happened my lxml was updated to a new version, that I started to get this problem. the error is
"File "iterparse.pxi", line 515, in lxml.etree.iterparse.next (src/lxml/lxml.etree.c:86643)
File "parser.pxi", line 565, in lxml.etree._raiseParseError (src/lxml/lxml.etree.c:64088)
lxml.etree.XMLSyntaxError: xmlParsePITarget: invalid name prefix 'xml', line 2, column 12"

From what I understand the new verison of lxml has change and I am not sure how to adapt my codes.

thanks

    Traceback (most recent call last):
      File "character.py", line 167, in <module>
        pds.field_area_repeat_2(template, 'Field_Character', template_1)
      File "/home/atmos2/dwhite12/Documents/Phoenix/pds_module.py", line 426, in field_area_repeat_2
        for action, template in context:

the code is calling a function that uses lxml.etree But i can comment that particular function out and it will give me the same error with the next function that uses lxml.etree

I feel as though you are over looking the fact that my functions have worked perfectly fine until something was updated on my system. I was simply asking if anyone has ran into an updating problem in the past. I am not sure what futher information I could possibly provide. I have no problem posting futher code(ie..my functions) if I can run across someone with experience with similar problems and productive advice... unfortunately i have clearly yet to come across this person.

This article has been dead for over six months. Start a new discussion instead.