0

Hello everybody. Lately, I'm having a problem with PyDev which is driving me crazy:

It is failing to connect to the Python console, therefore, many built-ins appear as errors (None, name, the os modules, etc.). I have tried downgrading PyDev, I have tried disabling IPv6, I have tried disabling my Linux firewall, I have tried re-installing everything and no luck...

This is rendering the entire IDE unusable because it keeps listing errors which are not: a simple x = None gives a "undefined variable None".

Another thing is that this error is not consistent, sometimes it connects to the python console, sometimes it doesn't.

I'm running Eclipse Juno on Mageia 2

I would appreciate any help, this is driving me crazy.

1
Contributor
1
Reply
18
Views
3 Years
Discussion Span
Last Post by G_S
0

OK I'll reply myself since I solved it on my own (I'm such a genius):

The problem was that some networking wizard I had recently used changed the name of the machine back to localhost, and pydev was still trying to connect to the Python shell using the old name. I restored the old name and voilĂ !

I'm amazing, I know.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.