Hi all,
I'm trying to open Acrobat.exe with WSH 5.6. Should be pretty easy right? lol My first problem was I had Acrobat 6.0, Acrobat 7.0 and Acrobat 8.0 all installed on my machine and I needed to browse into a sub folder of Acrobat 8.0. So the first thing I did was remove 6.0 & 7.0. Now I only need to worry about the 8.0 folder.
The only problem is WHS still can not find the folder. I've tried every combination of \acro~1 that I can with differing amounts of the word there and it still does not find it. It does not find \acrobat 8.0\ I think because of the space between t and 8.
The ~1 also does not work in my DOS shell.
Can someone speak to how the ~1 works and exactly what it does.

This is my line of code BTW:
[
WshShell.Run "C:\Progra~1\Adobe\Acrobat 8.0\Acrobat\ACROBAT.EXE"
]

It gets through Program Files fine, but not when I use a ~1 in the Acrobat 8.0 folder.

It seems like my only option now is to use the BrowseForFolder method or the SysDialog FileRun method.

Any other ideas?
Chris

The file name in msdos FAT16 Filesystem environment takes only 8 letters and an optional period(dot) and upto 3 character extension. You should have formated your drive with FAT32. So that long file name and extension can be given for a file. Windows recoup this compatibility problem by restricting to 8 letters. That is Six letters, a ~ sign and numbers 1 to 9 to distinguish those files whose first 6 characters are same.

Instead of acro~1, you shuld have given acroba~1. Try this one and get back to me.

Putting it in as \acroba~1\ still did not work. Interesting info about the whole ~ thing with DOS. What is the meaning for each number 1-9 when used with the ~?.
This is very strange. Acrobat 8.0 is now the only sub folder starting with Acrobat in that folder path and it still can not find it.
Chris

Now you just try the following things in your dos prompt

CD \
dir progra~1

the above command should list all the files and directories in the Program files folder
extend if as:
dir progra~1\adobe\acroba~1

~ sign will look after all the compatibilty problems such as long file name, space in file name etc.

if the files and directories under acrobat 8.0 is listed then nothing wrong with it.
reproduced is a directory listing in my computer

C:\>dir docume~1\admini~1\mydocu~1
Volume in drive C has no label.
Volume Serial Number is FCBE-C3EA
Directory of C:\docume~1\admini~1\mydocu~1
06/21/2007 02:20p <DIR> .
06/21/2007 02:20p <DIR> ..
06/21/2007 02:20p <DIR> My eBooks
06/21/2007 02:00p <DIR> My Pictures
0 File(s) 0 bytes
4 Dir(s) 38,807,257,088 bytes free

Something funky is going on with mine...

This is some sample DOS DIR stuff to show you what works and what doesn't. The Program Files DIR works when I use the tilda but it does not work when I use the tilda for Acrobat 8.0.

***BEGINNING OF DOS WINDOW***
C:\dir progra~1\adobe
Volume in drive C has no label.
Volume Serial Number is xxxx-xxxx

Directory of C:\progra~1\adobe

06/19/2007 08:45 AM <DIR> .
06/19/2007 08:45 AM <DIR> ..
06/13/2007 08:27 AM <DIR> Acrobat 8.0
06/13/2007 03:39 PM <DIR> Adobe Help Viewer
0 File(s) 0 bytes
4 Dir(s) 56,xxx... bytes free

C:\dir progra~1\adobe\acroba~1
Volume in drive C has no label.
Volume Serial Number is xxxx-xxxx

Directory of C:\progra~1\adobe

File Not Found
***END OF DOS WINDOW***

I've tried it with capitol A in Acrobat and it still doesn't work either way. I didn't think it was case sensitive but I just wanted to make sure.

This article has been dead for over six months. Start a new discussion instead.