Hi This is Scorp

I have Little issue about phpmyadmin.

When i write
http://localhost/phpmyadmin
on my url and Press Enter
i got the Login Screen
and i tries every username and password, but everytime it gives same error

Error
MySQL said:
#1045 - Access denied for user 'pma'@'localhost' (using password: YES)

I m stuck
Any help will be Appriciated
Regards Scorpion

Comments
scorpionz is a great person, excellent to talk to and a great listener.

i assume you have root access to the server to set configurations etc....

I am not a phpmyadmin maestro, so you might be better off posting this in a linux/wamp forum depending on your server type...I can just suggest a few troubleshooting techniques that I have come across in my experience.
--
is mysql running?
--
have you set a password for mysql root user yet? If not, enter a username without password. More on mysql passwords here: http://dev.mysql.com/doc/refman/5.0/en/adding-users.html
---
have you set up the phpmyadmin config? This can be a royal pain. Be sure to refer to the documentation here: http://wiki.cihar.com/pma/Welcome_to_phpMyAdmin_Wiki. Quick Install->configuration is a good place to start.

Grant privileges (using root account) to the user pma. I don't think pma have sufficient privileges.

So Guys How can i Fix this issue so as to get through to my wprk
Regards
Scorpion

So Guys How can i Fix this issue so as to get through to my wprk

Well, the best way to do that would be to remember the password you used.

In lieu of that, you can log in as the root user and modify the password for the user 'pma' to something new.

Here's how you do this in phpmyadmin, once you're logged in as the "root" account.

  • Click on "Privileges" tab
  • Find username 'pma' in the list
  • Click on the "Edit Privileges" icon all the way to the right
  • Scroll down to where it says "Change Password"
  • Select "Password" and enter a new password

If you don't know the password for the "root" account, you can re-set the password and then use the root account to reset the 'pma' account. Here's the relevant section of the mySQL documentation on re-setting the root password.

Good luck,
- Walkere

Sorry to say Guys, i am unable to solve the issue of login to phpmyadmin, let me give you more detail about my problem
I tried with every username and every password but but but nothing is working it is not logging, every time it generates same error,

Error
MySQL said:
#1045 - Access denied for user 'pma'@'localhost' (using password: YES)

I m stuck Guys.....

if any one can give some stepwise working scenario about setting username and password so i can start it phpmyadmin...

Regards
Scorpion

I cant event log in through root...
I dont know What to do?????
Regards
Scorpion

Well Thanks Naveen, but I have install Xampp on my laptop, not individually everything, and the website u provided me is for configuration of mysql separately
I need to configure it in Xampp.
Well Sorry to say it is still not solved yet

Regards
Scorpion

Hi scorpionz,

Go into your phpmyadmin directory and find a file called config.inc.php. Open this file and find the lines 72, and 73. Set line 72 to 'root' and line 73 to the root password you used when you installed it. If you didn't use a password when you installed it, then add a password in there that you will remember. After you have done this save the file, then see if you can login in. If you can log in, you can then have full control over phpmyadmin, you can then if you want to re-create a new user account. I hope this helps

No it is still not solved....
the website u provide me is not really helpful for my issue... after all Thanx
when i click on phpmyadmin
it just give an error page

MySQL said:
#1045 - Access denied for user 'pma'@'localhost' (using password: YES)

So men What to Dooo
Thanx in Advance

and my config file has these lines

$cfg[$i] = 'config'; // Authentication method (config, http or cookie based)?
$cfg[$i] = 'root'; // MySQL user
$cfg[$i] = ''; // MySQL password (only needed
// with 'config' auth_type)
$cfg[$i] = ''; // If set to a db-name, only
// this db is displayed in left frame
// It may also be an array of db-names, where sorting order is relevant.
$cfg[$i] = ''; // Verbose name for this host - leave blank to show the hostname

$cfg[$i] = 'phpmyadmin'; // Database used for Relation, Bookmark and PDF Features
// (see scripts/create_tables.sql)
// - leave blank for no support
// DEFAULT: 'phpmyadmin'

ok in your config file, change this line:

$cfg[$i] = ''; // MySQL password (only needed
// with 'config' auth_type)

to this:

$cfg[$i] = 'Yourpassword'; // MySQL password (only needed
// with 'config' auth_type)

Note where I wrote 'Yourpassword' in the code above, change this to whatever password you want. Once you have done this, save the file and log in phpmyadmin using your root account. You can then edit your user privileges when you are in there. It is not letting you in because you have no password in the line of code above. Try this and let me know how you went:)

$cfg[$i] = 'pma'; // MySQL control user settings
// (this user must have read-only
$cfg[$i] = 'secret'; // access to the "mysql/user"
// and "mysql/db" tables).
// The controluser is also
// used for all relational
// features (pmadb)
$cfg[$i] = 'config'; // Authentication method (config, http or cookie based)?
$cfg[$i] = 'root'; // MySQL user
$cfg[$i] = 'test'; // MySQL password (only needed
// with 'config' auth_type)
$cfg[$i] = ''; // If set to a db-name, only
// this db is displayed in left frame
// It may also be an array of db-names, where sorting order is relevant.
$cfg[$i] = ''; // Verbose name for this host - leave blank to show the hostname

$cfg[$i] = 'phpmyadmin'; // Database used for Relation, Bookmark and PDF Features
// (see scripts/create_tables.sql)
// - leave blank for no support
// DEFAULT: 'phpmyadmin'

I got the same Error i.e..
MySQL said:
#1045 - Access denied for user 'pma'@'localhost' (using password: YES)

Not Working Buddy... I m Stuck...

Thanx and Regards
Scorpion

hmm this is a tricky one, just a question, can you log in using your MySQL console?, if not you might have to re-install MySQL

if you can, try and re-install phpmyadmin:)

Thanx after all but richie
i m using Xampp not doing installation individually

So big issues around me
Buddy solve it i will be Thankful

Regards scorpion

Open mysql console and create a new user.

create user testuser;
grant all privileges on *.* to 'testuser'@'localhost';

This will create a new user called testuser with all the privileges. Use this user account in your script.

ok try changing this line:

$cfg[$i] = 'config'; // Authentication method (config, http or cookie based)?

to:

$cfg[$i] = 'http'; // Authentication method (config, http or cookie based)?

Notice that I have changed 'config' in the first line of code to 'http' in the second line of code, give this ago. This should bring up the login page for phpmyadmin, then try login from there!

Thanks for telling that but Naveen its giving this error when writing on Console

c:\xampp\mysql\bin\>mysql.exe -root
ERROR 1045 (28000): Access denied for user 'ODBC'@'localhost' (using password: NO)

Another Issue raised inside an issue
Men this is really unbelievable, I never have this Problem in my Office PC

Regards
Scorpion

its mysql -u root and mysql -u root -p password if your root has a password. Before that, you should have mysqld started. (ie, mysql server running!)

ODBC is the default user for windows if none as been assigned. to fix this, go to your command prompt and type in c:\xampp\mysql\bin\>mysql -u root
You should be able to grant privileges from there. Its worth a try:)

now its correct command
now i entered in mysql console
like
mysql>

Now what to write there?

ok now write exactly what Naveen posted earlier, heres the query again:

CREATE user testuser;
GRANT all PRIVILEGES on*.*to 'testuser'@'localhost';

Open mysql console and create a new user.

create user testuser;
grant all privileges on *.* to 'testuser'@'localhost';

This will create a new user called testuser with all the privileges. Use this user account in your script.

?

To Naveen
I apply both the queries i got the same result from these queries
i.e
Query OK, 0 rows affected (0.00 sec)

Now i check that again at http://localhost:800/phpmyadmin
but same error


To Richie
Richie I did that before... of about changing config to http
and i got this time an alert type Authentication ... in which it asks for
user name and Password
I give
user name :root
password: test

As u already saw my config file....

But these username not working at all
Now i m Stuck as i have search it everywhere on the internet

Regards
Scorpion

Ok try this at the mysql console.

1: CREATE user root;
2: GRANT all PRIVILEGES on *.* to 'root'@'localhost' identified by 'test';

Then go back to phpmyadmin, and try to login again. If it doesnt work this time, you might have to back up your databases and do a complete xampp re-install!

Just one more question, are you entering a password to access the mysql console, if so what is it?

Well Richie as mention by your side regarding this concern of queries

i got this result after running that...

Query OK, 0 rows affected (0.00 sec)

now your question is
are you entering a password to access the mysql console, if so what is it?

Answer:
I am not entering any Password to enter in mysql, simple is that... i have installed Xampp and i hope u know it Well Xampp consists of everything... like JUST Install and Run it...
But this case really becomes Exceptional for me... as u people can think... that this should not be the issue... but it is...
and i install Xampp 3 times...
So hope u can understand

Thanks and Regards
Scorpion

Well, It wont go wrong unless you have made any mistake. Now open config.inc.php file in your phpmyadmin and change the username.

$cfg[$i] = 'testuser';
$cfg[$i] = '';

If even this doesn't work, then, install wamp.

I agree with Naveen, if it doesn't work this time, uninstall xampp and download and install wamp. I used to run xampp and had so much trouble with it. wamp is way much easier to use and gives you access to everything.

This question has already been answered. Start a new discussion instead.