I have a data layer class built with the dataset designer that I have added as a reference (compiled dll) in a project. When I run the app locally from Visual Studio, it runs just fine. However when I move it to the hosted server, I get "Type 'H2C2DataLayer.h2c2DataSet.topicsDataTable' is not defined."

Here's some code:

Try
  Dim adp_hotTopic As H2C2DataLayer.h2c2DataSet.topicsDataTable = GetTopics()

  rptNav.DataSource = adp_hotTopic
  rptNav.DataBind()

Catch ex As Exception
  lblDiagnostics.Text = ex.Message & "<br />" & ex.StackTrace
End Try

For some reason, it errors out on line 2, even though it's inside a try/catch. Can't figure that one out either. The exception should be caught and dumped to the diagnostics label.

Here's some code from the class:

Public Class Data
        Public Shared Function GetTopics() As h2c2DataSet.topicsDataTable
            Dim dt As New h2c2DataSet.topicsDataTable
            Dim taTopics As New h2c2DataSetTableAdapters.topicsTableAdapter

            dt = taTopics.GetData()

            Return dt
        End Function
  End Class

There's obviously more to the class, but it doesn't matter because whatever function I call, I get the same error.

First i would try using standard DataTables as it is possible that the server has not got the prerequisites installed for H2C2DataLayer.h2c2DataSet.topicsDataTable

Try

Dim SQLTable as new DataTable

Thanks for the feedback. It turns out that it was actually a problem on the server. I talked to the person in charge of our hosting servers and he said that the folder was configured as an app under the virtual directory, but not the virtual host. Once he changed that, it worked perfectly.

I never realized there was a difference. Not that it matters because I don't have control over that anyway and would have never known.

This question has already been answered. Start a new discussion instead.